helpf.pro
Регистрация
 +2 
Распечатать

Как таблицу значений выгрузить в Excel

Код 1C v 8.х
 
Процедура ВыгрузкаВЭксель(Т) Экспорт
Попытка
XL = Новый COMОбъект ("Excel.Application");
Исключение
Сообщить("Ошибка создания Excel.Application");
Возврат;
КонецПопытки;
XL.Visible = 1;
wb = XL.Workbooks.Add();
sh = wb.Worksheets.Add();
Кол = Т.Колонки.Количество();
Если Кол = 0 Тогда
Возврат;
КонецЕсли;
Для К = 1 По Кол Цикл
Заг = Т.Колонки[К-1].Имя;
sh.Cells(1,К).Font.Name = "Tahoma";
sh.Cells(1,К).Font.Size = 10;
sh.Cells(1,К).Font.FontStyle = "Bold";
sh.Cells(1,К).FormulaR1C1 = Заг;
КонецЦикла;
Для Каждого Стр Из Т Цикл
Для К = 1 По Кол Цикл
Зн = Стр[К-1];
sh.Cells(Т.Индекс(Стр)+2, К).FormulaR1C1 = Строка(Зн);
КонецЦикла;
КонецЦикла;
sh.Columns.AutoFit();
КонецПроцедуры
Разместил:   Версии: | 8.x |  Дата:   Прочитано: 13051
 +2 
Распечатать
Возможно, вас также заинтересует
Как заполнить табличную часть формы программно? 2
Нужно по кнопке Заполнить - сформировать данные для заполнения табличных частей и заполнить их. Форма имеет вид: Рядом с кнопкой Записать и закрыть добавлена кнопка Заполнить документ , код ее команды: // Код...
Excel файл как Внешний источник данных 4
Подключимся и загрузим из файла Excel данные в таблицу значений 1С. Сделать теперь это очень просто. 1. В конфигурации добавляет новый объект метаданных типа " Внешние источники данных" и назовем его просто " Excel" . ...
Автоматизация обмена данных используя обработку "Универсальный обмен данными в формате XML" 3
Автоматизация обмена между базами используя обработку " Универсальный обмен данными в формате XML" В основу данной публикации положены найденные мною материалы по cозданию обмена между двумя базами с использованием ...
Активация открытой книги Excel для корректировки 0
Нужно было получить для изменения уже открытую книгу Excel, а если она закрыта, то открыть и изменять. Ниже код, который данную задачу решает. Попытка Эксель = Неопределено; Книга = Неопределено; Лист = Неопределено; ...
База 1С вылетает, виснет, не грузится, падает с ошибкой? 0
Есть ряд методов, которыми можно попытаться " поднять" упавшую базу 1С 8.х Но сперва нужно сделать резервную копию! Сделайте резервную копию простым копированием папки базы, выгрузка не всегда может быть корректна. ...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.