helpf.pro
Регистрация
 +1 
Распечатать

1С 7.x : Ввести дату, ввод даты

Код 1C v 8.х
 
ДатаНапоминания = РабочаяДата;
Подсказка = "Введите дату и время";
ЧастьДаты = ЧастиДаты.ДатаВремя;
Если ВвестиДату(ДатаНапоминания, Подсказка, ЧастьДаты) Тогда
// обработка даты напоминания
КонецЕсли


Код 1C v 7.x
 
Если ВвестиДату(Д, "Введите дату ссуды") = 1 Тогда
ДатаСсуды = Д;
Иначе
ВидРасчета = ВидРасчета.БеспроцентнаяСсуда;
КонецЕсли;
Разместил:   Версии: | 7.x | 8.x |  Дата:   Прочитано: 14567
 +1 
Распечатать
Возможно, вас также заинтересует
Альтернативный перенос остатков между 7.7 и 8.1 (обработкой с ИТС ЗагрузкаДанныхИзТаблДокум) 0
Нашел альтернативный, практически моментальный способ переноса остатков между семерой и восьмерой (так и между восмерками). Не требуется никаких дополнительных усилий, программирования, писания обработок и т.д. и т.п....
В 1С не вводится новый элемент в справочник 0
Новый элемент или группу в справочник нельзя добавить если выключен режим иерархического списка. Для того, чтобы включить этот режим выберите в меню " Действия" пункт " Иерархический список" и установите этот режим.
Ввести значение, ввод значения 0
//Пример универсального ввода значения Перем ВыбЗнач; Массив = Новый Массив; Массив.Добавить(Тип("Число")); Массив.Добавить(Тип("Строка")); Массив.Добавить(Тип("Дата")); КЧ = Новый КвалификаторыЧисла(12,2); КС = Новый...
Ввести строку, ввод текста 0
Текст = ""; Подсказка = "Введите текст напоминания"; Если ВвестиСтроку(Текст,Подсказка, 0, истина) Тогда // запомнить текст напоминания КонецЕсли; НК = ""; Если ВвестиСтроку(НК, "Введите код продукции", 40, 1, 9) = 1 Тогда Koд...
Ввести число, ввод числа 1
КолВо = 1; Если ВвестиЧисло(КолВо, "Введите количество", 10, 2) Tогда // обработка введенного количество КонецЕсли; Если ВвестиЧисло(Ном, "Введите номер приказа", 5, 0, 10) = 1 Тогда ВыбДок = СоздатьОбъект("Документ.Приказ"); ...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.