helpf.pro
Регистрация
 0 
Распечатать

1С 7.x : Удаление из строки всех нечисловых символов

Иногда необходимо избавиться от нечисловых символов в строке. Например если сканер штрихкода или ридер магнитных карт добавляют в считываемую строку свои служебные символы.

Вот нехитрая функция для решения этой задачи

Код 1C v 7.x
 
Функция УбратьНечисловые(Стр)
ОбрСтр = СокрЛП(Стр);
Результат = ОбрСтр;
Для н=1 по СтрДлина(ОбрСтр) Цикл
ТекСимвол = Сред(ОбрСтр,н,1);
Если Найти("0123456789",ТекСимвол) = 0 Тогда
Результат = СтрЗаменить(Результат,ТекСимвол,"");
КонецЕсли;
КонецЦикла;
Возврат Результат;
КонецФункции
Разместил:   Версии: | 7.x | 8.x | 8.2 УП |  Дата:   Прочитано: 8940
 0 
Распечатать
Возможно, вас также заинтересует
Автоматическая установка ширины колонки табличного документа. 0
Процедура, которая " примерно" делает автоширину колонок (навроде, как если бы выделить все колонки и дважды щелкнуть мышкой по границе заголовка колонки). Привожу текст, работает неахти, но лучше чем ничего: Процедура...
Алгоритм шифрования RC4 0
Для решения некоторых задач, иногда требуется имееть возможность шифровать и дешифровывать, какие-то данные. Но при этом нет возможности использовать стороние внешнии компоненты. Предлагаем пример реализации...
Выгрузка / Загрузка данных посредством текстовых (TXT) файлов 2
Для работы с текстовыми документами существуют три типа данных – ТекстовыйДокумент, ЗаписьТекста и ЧтениеТекста . Разница двух подходов состоит в способе загрузки документа: ТекстовыйДокумент загружает файл...
Использование ASCII кодов в 1С 2
Хотите писать в 1С не только стандартными буквами, знаками изображенными на клавиатуре и вставлять опять же стандартные смайлики, а тем не менее существует возможность ставить дополнительные символы, так же можно...
Как настроить отображение даты? Год - 4 символа? 0
Есть сотрудник 1946 года рождения. Программа не пропускает этот год, а выдает 2046 год. И, соответствено, выдает ошибку. Изменить год начала рабочего столетия и поменять количество символов в представлении даты. Делается...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.