helpf.pro
Регистрация
 +2 
Распечатать

1С 7.x : Задать вопрос пользователю, ответ на вопрос

Код 1C v 8.2 УП
 Режим = РежимДиалогаВопрос.ДаНетОтмена;
Ответ = Вопрос("Выполнить?", Режим, 0);

Если Ответ =КодВозвратаДиалога.Да Тогда
Сообщить("Выполнено");
ИначеЕсли Ответ = КодВозвратаДиалога.Нет Тогда
Сообщить("Не выполнено");
КонецЕсли;



Код 1C v 8.х
 
Режим = РежимДиалогаВопрос.ДаНет;
Ответ = Вопрос("Сохранить текст?", Режим,0) ;
Если Ответ = КодВозвратаДиалога.Нет Тогда
ТекДок.Записать(ПутьКФайлу);
КонецЕсли ;

//Свойства РежимДиалогаВопрос:
//ДаНет (YesNo)
//ДаНетОтмена (YesNoCancel)
//ОК (OK)
//ОКОтмена (OKCancel)
//ПовторитьОтмена (RetryCancel)
//ПрерватьПовторитьПропустить (AbortRetryIgnore)

//Свойства КодВозвратаДиалога:
//Да (Yes)
//Нет (No)
//ОК (OK)
//Отмена (Cancel)
//Повторить (Retry)
//Прервать (Abort)
//Пропустить (Ignore)
//Таймаут (Timeout)


Код 1C v 7.x
 
// Зададим вопрос, и варианты ДА, НЕТ
Рез = Вопрос("Вы получили данное сообщение?", 4);
// При нажатии Да - Рез=6, Нет- Рез=6

//Можно и так:
Если Вопрос("Сохранить?", "Да+Нет") = "Да" Тогда
ТекДок.Записать(ПутьКФайлу);
КонецЕсли;

//Вопрос(Текст_вопроса, Режим, Таймаут) - Вывести окно вопроса и получить ответ.
//Возвращает ответную реакцию в виде числа или строки, в соответствии с заданием параметра <Режим>:
//-1 или 'Таймаут' ('Timeout'), если закончилось время ожидания ответа;
//1 или 'ОК' ('ОК'), если если нажата кнопка OK;
//2 или 'Отмена' ('Cancel'), если нажата кнопка Отмена;
//3 или 'Стоп' ('Abort'), если нажата кнопка Стоп;
//4 или 'Повтор' ('Retry'), если нажата кнопка Повтор;
//5 или 'Пропустить' ('Ignore'), если нажата кнопка Пропустить;
//6 или 'Да' ('Yes'), если нажата кнопка Да;
//7 или 'Нет' ('No'), если нажата кнопка Нет.
//
//Параметры:
//Текст_вопроса - cтрока текста вопроса;
//Режим - определяет набор кнопок диалога в виде числа или строки (в скобках английское написание):
// 0 или 'ОК' ('ОК') - кнопка OK;
// 1 или 'ОК+Отмена' ('OK+Cancel') - кнопки OK и Отмена;
// 2 или 'Стоп+Повтор+Пропустить' ('Abort+Retry+Ignore') - кнопки Стоп, Повтор, Пропустить;
// 3 или 'Да+Нет+Отмена' ('Yes+No+Cancel') - кнопки Да, Нет, Отмена;
// 4 или 'Да+Нет' ('Yes+No') - кнопки Да, Нет;
// 5 или 'Повтор+Отмена' ('Retry+Cancel') - кнопки Повтор, Отмена;
// (любое другое значение или отсутствие параметра равносильно 0);
//Таймаут - число секунд времени ожидания ответа (если опущен или 0, то без ограничения).
Разместил:   Версии: | 7.x | 8.x | 8.2 УП |  Дата:   Прочитано: 23164
 +2 
Распечатать
Возможно, вас также заинтересует
1С Предприятие что это? 6
Что такое 1С? 1С — это фирма , у которой одно из направлений деятельности — разработка программного обеспечения для автоматизации бизнес-процессов предприятий. « 1С:Предприятие » - конкретный продукт, который...
Cклонения по падежам 4
НаКлиенте Процедура Команда1(Команда) ФИО = " Иванов Иван Иванович" ; Падеж = 2; Пол = 1; Результат = СклонениеФИО(ФИО, Падеж, пол); Сообщить(Результат); КонецПроцедуры НаСервере Функция СклонениеФИО(ФИО, Падеж, пол) ...
Автоматическая установка ширины колонки табличного документа. 0
Процедура, которая " примерно" делает автоширину колонок (навроде, как если бы выделить все колонки и дважды щелкнуть мышкой по границе заголовка колонки). Привожу текст, работает неахти, но лучше чем ничего: Процедура...
Алгоритм шифрования RC4 0
Для решения некоторых задач, иногда требуется имееть возможность шифровать и дешифровывать, какие-то данные. Но при этом нет возможности использовать стороние внешнии компоненты. Предлагаем пример реализации...
Альтернативный перенос остатков между 7.7 и 8.1 (обработкой с ИТС ЗагрузкаДанныхИзТаблДокум) 0
Нашел альтернативный, практически моментальный способ переноса остатков между семерой и восьмерой (так и между восмерками). Не требуется никаких дополнительных усилий, программирования, писания обработок и т.д. и т.п....
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.