helpf.pro
Регистрация
 0 
Распечатать

1С 7.x : Функция преобразования строки вида ДебиторкаПоКонтрагентам в Дебиторка по контрагентам

Примеры кода для 7 версии, но будут работать и в 8-ой

Код 1C v 7.x
  Функция мРазнПреобразоватьСтрокуСБольшимиБуквами(ИсходнаяСтрока) Экспорт

СтрокаВозврата = Сред(ИсходнаяСтрока, 1, 1);

Для Сч = 2 По СтрДлина(ИсходнаяСтрока) цикл
ПредСимвол = Сред(ИсходнаяСтрока, Сч - 1, 1);
ТекСимвол = Сред(ИсходнаяСтрока, Сч, 1);
СледСимвол = Сред(ИсходнаяСтрока, Сч + 1, 1);

Если ВРЕГ(ТекСимвол) = ТекСимвол тогда
Если ВРЕГ(ПредСимвол) <> ПредСимвол тогда
СтрокаВозврата = СтрокаВозврата + " ";
Если ВРЕГ(СледСимвол) <> СледСимвол тогда
ТекСимвол = НРЕГ(ТекСимвол);
КонецЕсли;
КонецЕсли;
КонецЕсли;

СтрокаВозврата = СтрокаВозврата + ТекСимвол;

КонецЦикла;

Возврат СтрокаВозврата;

КонецФункции // мРазнПреобразоватьСтрокуСБольшимиБуквами()


А таким кодом, просто перед большой буквой выставляется пробел:
Код 1C v 7.x
 
Список=новый СписокЗначений;
Для н=КодСимвола("А") По КодСимвола("Я") Цикл
Список.Добавить(Символ(н));
КонецЦикла;
Значение="ДебиторкаПоКонтрагентам";
Результат="";
Для н=1 По СтрДлина(Значение) Цикл
Сим=Сред(Значение,н,1);
Если Список.НайтиПоЗначению(Сим) <> Неопределено Тогда
Сим=" "+Сим;
КонецЕсли;
Результат=Результат+Сим;
КонецЦикла;
Сообщить(Результат);
Разместил:   Версии: | 7.x |  Дата:   Прочитано: 5209
 0 
Распечатать
Возможно, вас также заинтересует
1С Предприятие что это? 6
Что такое 1С? 1С — это фирма , у которой одно из направлений деятельности — разработка программного обеспечения для автоматизации бизнес-процессов предприятий. « 1С:Предприятие » - конкретный продукт, который...
Microsift Visual C++ Runtime Library Program ...1cv77s.exe abnormal program termination 0
При запуске 1С 7.7 выдает сообщение: Microsift Visual C++ Runtime Library Program C:Program Files1Cv77BIN1cv77s.exe abnormal program termination Вариант 1. Обычно это происходит, когда повреждается файл регистрации. Точнее, когда не дописывает
Автоматическая установка ширины колонки табличного документа. 0
Процедура, которая " примерно" делает автоширину колонок (навроде, как если бы выделить все колонки и дважды щелкнуть мышкой по границе заголовка колонки). Привожу текст, работает неахти, но лучше чем ничего: Процедура...
Вывод (печать) таблицы значений в табличный документ 4
Пример кода быстрая Печать таблицы значений //ТПОтчета - Табличное поле с формы (Таблица значений) с данными ПострПечать = Новый ПостроительОтчета; ПострПечать.ИсточникДанных = Новый...
Значение поля "Код" не уникально или Значение поля "Номер" не уникально 0
При работе в 1С, особенно когда много документов или номера редактируются ручками, можно получить ошибки вида: Значение поля "Код" не уникально или Значение поля "Номер" не уникально Что делать? Перенумеровывать :) ...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.