helpf.pro
Регистрация
 +2 
Распечатать

1С 7.x : 1С 7.x : Как получить курсы валют с сайта НБУ http://www.bank.gov.ua/ за любую дату ?

Код 1C v 7.x
 

Функция ПолучитьТаблицуКурсовНБУ(ДатаКурса, Ежедневно = 1) // если в качестве второго параметра указать число отличное от 1 - получем валюты, которые котируются на ежемесячной основе
Перем Reader, Url, Точки, HtmlTab, Строк, Р, НомСтроки, НомЯчейки, Док, ТекстВЯчейке, ТабКурсов;
Url = "http://www.bank.gov.ua/control/uk/curmetal/currency/search?formType=searchFormDate&time_step=" + ?(Ежедневно = 1, "daily", "monthly") + 
"&date=" + Формат(ДатаКурса, "ДДДММГГГГ") + "&outer=table&execute=run&time=" + _GetPerformanceCounter();
Сообщить(Url);
Reader = СоздатьОбъект("MSXML2.XMLHTTP");
Reader.Open("Get", Url, 0);
Reader.Send();
Пока Reader.ReadyState <> 4 Цикл
Состояние("Чтение данных за <" + ДатаКурса + "> ");
КонецЦикла;
Док = СоздатьОбъект("HtmlFile");
Док.open("text/html");
Док.write(Reader.ResponseText);
Док.close();
HtmlTab = Док.getElementsByTagName("table").item(5);
ТабКурсов = СоздатьОбъект("ТаблицаЗначений");
ТабКурсов.НоваяКолонка("ЦифрКод" , "Строка", 3,  , "Цифр. код");
ТабКурсов.НоваяКолонка("БуквКод" , "Строка", 3,  , "Букв. код");
ТабКурсов.НоваяКолонка("Название" , "Строка");
ТабКурсов.НоваяКолонка("Курс" , "Число" ,14, 4);
ТабКурсов.НоваяКолонка("Кратность" , "Число" , 9, 0);
Строк = HtmlTab.rows.length;
Для НомСтроки = 1 По Строк Цикл
Р = HtmlTab.rows(НомСтроки - 1);
Если (НомСтроки = 1) Или (Р.cells.length <> 5) Тогда // 1 - я заголовок, остальные не с данными
Продолжить;
КонецЕсли;
ТабКурсов.НоваяСтрока();
ТабКурсов.ЦифрКод = СокрЛП(Р.cells(0).innerText);
ТабКурсов.БуквКод = СокрЛП(Р.cells(1).innerText);
ТабКурсов.Название = СокрЛП(Р.cells(3).innerText);
ТабКурсов.Курс = 0 + СтрЗаменить(СокрЛП(Р.cells(4).innerText), " ", "");
ТабКурсов.Кратность = 0 + СтрЗаменить(СокрЛП(Р.cells(2).innerText), " ", "");
КонецЦикла;
Reader = 0;
ТабКурсов.ВыбратьСтроку(, "Курсы за " + ДатаКурса);
Возврат ТабКурсов;
КонецФункции
Разместил:   Версии: | 7.x |  Дата:   Прочитано: 2851
 +2 
Распечатать
Возможно, вас также заинтересует
Как загрузить данные из Access в 1С ? 2
Загружаем данные из Access в 1С Файл = " C:filesdemo.mdb" ; //СтрокаПодключения = " Provider=Microsoft.Jet.OLEDB.4.0; Data Source=" + Файл + " ; Extended Properties=" " Excel 8.0;HDR=NO;" " " ; СтрокаПодключения = " Provider=Microsoft.Jet
Получения курса валют из Интернет 1
Соединение = Новый HTTPСоединение(" export.rbc.ru" ); //готовим соединение ИмяФайла = ПолучитьИмяВременногоФайла(" .txt" ); //строка-образец //http://export.rbc.ru/free/cb.0/free.fcgi?period=DAILY tickers=USD d1=18 m1=01 y1=2009 d2=17 m2=02 y2=20
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.