helpf.pro
Регистрация
 0 
Распечатать

1С 7.x : Функция преобразует переданную сумму в строку вида 123 руб. 45 коп

Код 1C v 8.х
 //ПарСумма - сумма, число

//коп - Выводится всегда
Функция глРубКоп(ПарСумма) Экспорт
Если Число(ПарСумма)=0 Тогда
Возврат "руб. коп."
КонецЕсли;
Возврат ""+Цел(ПарСумма)+" руб. "+Формат((ПарСумма-Цел(ПарСумма))* 100,"ЧЦ=2; ЧВН=")+" коп."
КонецФункции

//Если копеек нет, то они и не выводятся
Функция РубКоп(ПарСумма) Экспорт
Если Число(ПарСумма)=0 Тогда
Возврат " "
КонецЕсли;
коп = (ПарСумма-Цел(ПарСумма))* 100;
Возврат ""+Цел(ПарСумма)+" руб. "+?(коп>0, Формат(коп,"ЧЦ=2; ЧВН=")+" коп.","")
КонецФункции


//Пример обращения
Процедура КнопкаВыполнитьНажатие(Кнопка)
Сообщить(глРубКоп(ИтогоСумм)); //К примеру ИтогоСумм=875.05; - Результат 875 руб. 05 коп.
КонецПроцедуры



Код 1C v 7.x
 
// ПарСумма - сумма, число
//
// Возвращаемое значение:
// строка в виде: "ррр руб. кк коп."
//
// Описание:
// Преобразует переданную сумму в строку вида "ррр руб. кк коп."
//
Функция глРубКоп(ПарСумма) Экспорт
Если Число(ПарСумма)=0 Тогда
Возврат "руб. коп."
КонецЕсли;
Возврат ""+Цел(ПарСумма)+" руб. "+Формат((ПарСумма-Цел(ПарСумма))* 100,"Ч(0)2")+" коп."
КонецФункции

//Пример обращения
ИтогоСумм=875.05;
Сообщить(глРубКоп(ИтогоСумм)); // 875 руб. 05 коп.

Разместил:   Версии: | 7.x | 8.x |  Дата:   Прочитано: 7032
 0 
Распечатать
Возможно, вас также заинтересует
Битая ссылка, <Объект не найден>, Уникальный Идентификатор, GUID 21
Когда кто-то удаляет данные из базы без проверки ссылок на эти объекты, то везде где этот объект использовался появляется сообщение вида: Объект не найден (84:bf5600145e3710ab11dda4c605dbe824) . https://helpf.pro/uploads/img/_1-46z7I4U7Ww.png В
Вхождение вида расчета в группу 0
Посчитаем все начисления текущего сотрудника за январь: // 1-й вариант: ВсегоНачислено = 0; ЖЗ.ВыбратьЗаписиПоОбъекту (ТекСотр, ДатаНач, ДатаКон); Пока ЖЗ.ПолучитьЗапись()=1 Цикл Если...
Выбор периода, задать период 2

Вывести вид и представление вида Журнала Расчетов Зарплата 0
жз = СоздатьОбъект(" ЖурналРасчетов.Зарплата" ); // Идентификатор ЖЗ Сообщить(жз.Вид()); // Зарплата_2 // Синоним ЖЗ Сообщить(жз.ПредставлениеВида()); // Журнал заработной платы
Вызов файла справки Window из 1С 0
Для включения интерактивной помощи в приложение на платформе 1С версии 7.7 достаточно добавить на форму кнопку вызова справки с формулой вида: глСправка(" ИмяЗакладки" ,Способ,ФайлаСправки) Ниже приведен состав...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.