helpf.pro
Регистрация
 -1 
Распечатать

Как проверить целое число? Четное число?

Код 1C v 8.х
 Функция ЧетноеЧисло(пЧисло)    
Четное = пЧисло%2=0;
Возврат Четное;
КонецФункции


Код 1C v 8.х
 
Функция ровноеЧисло(пЧисло)
Четное = пЧисло%2=1;
Возврат Четное;
КонецФункции

//или

Фунция ДровноеЧисло (Чис)
Возврат Чис = Цел(Чис);
КонецФункции


Код 1C v 7.x
 Функция ДробноеЧисло (Чис)
Возврат ?(Чис = Цел(Чис),1,0);
КонецФункции
Разместил:   Версии: | 7.x | 8.x | 8.2 УП |  Дата:   Прочитано: 7698
 -1 
Распечатать
Возможно, вас также заинтересует
1C и Google Maps 12
была поставлена задача отображения на географической карте медицинских учреждений. После обзора предлагаемых решений был выбран сервис google. Но так же подобного рода подход будет работать и с картами сервиса yandex. Во...
1С 7.x : Как получить курсы валют с сайта НБУ http://www.bank.gov.ua/ за любую дату ? 2
Функция ПолучитьТаблицуКурсовНБУ(ДатаКурса, Ежедневно = 1) // если в качестве второго параметра указать число отличное от 1 - получем валюты, которые котируются на ежемесячной основе Перем Reader, Url, Точки, HtmlTab, Строк, Р,...
Cклонения по падежам 4
НаКлиенте Процедура Команда1(Команда) ФИО = " Иванов Иван Иванович" ; Падеж = 2; Пол = 1; Результат = СклонениеФИО(ФИО, Падеж, пол); Сообщить(Результат); КонецПроцедуры НаСервере Функция СклонениеФИО(ФИО, Падеж, пол) ...
QR код в 1С 10
Столкнулся с интересной задачей реализации генерации QR-кода в 1С 8.2 ( QR-код — матричный код (двухмерный штрихкод) ) Для генерации было использовано api от google (http://chart.apis.google.com/chart). Вот сайт , который работает с ним. После...
Автоматическая установка ширины колонки табличного документа. 0
Процедура, которая " примерно" делает автоширину колонок (навроде, как если бы выделить все колонки и дважды щелкнуть мышкой по границе заголовка колонки). Привожу текст, работает неахти, но лучше чем ничего: Процедура...
Посмотреть все результаты поиска похожих
Комментарии
valiylab
19.08.2016 13:53Комментарий: 1
valiylab
Код 1C v 8.х
 Цел(х/2) = х/2 //возваращет истина если четное   
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.