helpf.pro
Регистрация
 0 
Распечатать

1С 7.x : Получить список Справочников конфигурации

Код 1C v 8.2 УП
 &НаКлиенте
Процедура ПоКнопкеЧтениеИзМетаданных(Команда)
// Вставить содержимое обработчика.
Перем СписокСправочников;

СписокСправочников = Новый СписокЗначений;
СписокСправочников = СправочникиИзМетаданных();
Для Сч = 0 По СписокСправочников.Количество() - 1 Цикл
Сообщить(СписокСправочников.Получить(Сч))
КонецЦикла;

КонецПроцедуры

&НаСервере
Функция СправочникиИзМетаданных()

Перем СписокСправочников, СправочникИзМетаданных;
СписокСправочников = Новый СписокЗначений;
Для Каждого СправочникИзМетаданных Из Метаданные.Справочники Цикл
СписокСправочников.Добавить(СправочникИзМетаданных.Имя);
КонецЦикла;

Возврат СписокСправочников;

КонецФункции



Код 1C v 8.х
 //ЭлементыФормы.ОбъектПоиска - Поле Выбора на форме
СписокВыбора = ЭлементыФормы.ОбъектПоиска.СписокВыбора;
Для Каждого Справочник Из Метаданные.Справочники Цикл
//Проверим, есть ли права на просмотр? Да- добавляем, Нет - пропускаем
Если ПравоДоступа("Просмотр", Справочник) Тогда
ИмяСправочника = Справочник.Синоним;
Если ИмяСправочника = "" Тогда
ИмяСправочника = Справочник.Имя;
КонецЕсли;
Структура = Новый Структура;
Структура.Вставить("Тип", "Справочник");
Структура.Вставить("Объект", Справочник);
СписокВыбора.Добавить(Структура, ИмяСправочника, ,ЭлементыФормы.КартинкаСправочника.Картинка);
КонецЕсли;
КонецЦикла;



Код 1C v 7.x
 	//Выведем список всех справочников в окно сообщений
Для Индекс=1 По Метаданные.Справочник() Цикл
Значение = Метаданные.Справочник(Индекс).Идентификатор;
Представление = Метаданные.Справочник(Индекс).Представление();
Комментарий = Метаданные.Справочник(Индекс).Комментарий;
Сообщить(Значение+" "+Представление+" "+Комментарий);
КонецЦикла;
Разместил:   Версии: | 7.x | 8.x | 8.2 УП |  Дата:   Прочитано: 19504
 0 
Распечатать
Возможно, вас также заинтересует
1С Предприятие что это? 6
Что такое 1С? 1С — это фирма , у которой одно из направлений деятельности — разработка программного обеспечения для автоматизации бизнес-процессов предприятий. « 1С:Предприятие » - конкретный продукт, который...
Выгрузка / Загрузка данных посредством XML файлов? 0
В основе работы с XML-файлами лежит технология доступа SAX, которая осуществляет считывание по одному тегу. Для этого существует два типа данных – ЗаписьXML и ЧтениеXML . Запись данных справочника в XML-файл: Запись = Новый...
Выгрузка метаданных конфигурации в Microsoft Word и Excel 0
Перем ОбъектыКонфы; Перем СтруктКонфы; Процедура ВыгрузитьВWord() Попытка Word = Новый COMОбъект(" Word.Application" ); Исключение Сообщить(" Не удалось открыть Word" ); Возврат; КонецПопытки; Word.Documents.Add(); Документ = Word.Activ
Есть ли у текущего элемента подчиненные 0
Выборка = Справочники.Номенклатура.Выбрать( , Владелец); Если Выборка.Следующий() = Истина Тогда // Есть подчиненные элементы. КонецЕсли; Запрос = Новый Запрос; Запрос.Текст = " ВЫБРАТЬ ПЕРВЫЕ 1 ...
Запрет ввода новых документов в архивную базу. 0
Процедура глЗаполнитьШапку(Конт, Скопирован=0) Экспорт ... //Блокировка ввода новых документов СтатусВозврата(0); ... КонецПроцедуры Хотя наиболее правильно будет изменять права пользователей, т.к. необходимо будет...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.