helpf.pro
Регистрация
 0 
Распечатать

1С 7.x : Копирование подчиненных элементов справочника из группы Источник в группу Цель

Код 1C v 7.x
 
Справ=СоздатьОбъект("Справочник.Задания");
Справ2=СоздатьОбъект("Справочник.Задания");
Справ.ИспользоватьВладельца(Цель);
Справ2.ИспользоватьВладельца(Источник);
Справ.ИспользоватьДату(НаДату);
Справ2.ИспользоватьДату(НаДату);

Справ2.ВыбратьЭлементы();
Пока Справ2.ПолучитьЭлемент()>0 Цикл
Справ.Новый();
Справ.Записать();
МетаСправочник=Метаданные.Справочник(Справ.Вид());
Для Счетчик=1 По МетаСправочник.Реквизит() Цикл
МетаРеквизит=МетаСправочник.Реквизит(Счетчик);
Идентификатор=Строка(МетаРеквизит.Идентификатор);
Значенице=Справ2.ПолучитьАтрибут(Идентификатор);
Справ.УстановитьАтрибут(Идентификатор,Значенице);
КонецЦикла;
Справ.Записать();
КонецЦикла;
Разместил:   Версии: | 7.x |  Дата:   Прочитано: 5636
 0 
Распечатать
Возможно, вас также заинтересует
Cклонения по падежам 4
НаКлиенте Процедура Команда1(Команда) ФИО = " Иванов Иван Иванович" ; Падеж = 2; Пол = 1; Результат = СклонениеФИО(ФИО, Падеж, пол); Сообщить(Результат); КонецПроцедуры НаСервере Функция СклонениеФИО(ФИО, Падеж, пол) ...
Алгоритм шифрования RC4 0
Для решения некоторых задач, иногда требуется имееть возможность шифровать и дешифровывать, какие-то данные. Но при этом нет возможности использовать стороние внешнии компоненты. Предлагаем пример реализации...
Битая ссылка, <Объект не найден>, Уникальный Идентификатор, GUID 21
Когда кто-то удаляет данные из базы без проверки ссылок на эти объекты, то везде где этот объект использовался появляется сообщение вида: Объект не найден (84:bf5600145e3710ab11dda4c605dbe824) . https://helpf.pro/uploads/img/_1-46z7I4U7Ww.png В
В 1С не вводится новый элемент в справочник 0
Новый элемент или группу в справочник нельзя добавить если выключен режим иерархического списка. Для того, чтобы включить этот режим выберите в меню " Действия" пункт " Иерархический список" и установите этот режим.
Вхождение вида расчета в группу 0
Посчитаем все начисления текущего сотрудника за январь: // 1-й вариант: ВсегоНачислено = 0; ЖЗ.ВыбратьЗаписиПоОбъекту (ТекСотр, ДатаНач, ДатаКон); Пока ЖЗ.ПолучитьЗапись()=1 Цикл Если...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.