helpf.pro
Регистрация
 0 
Распечатать

1С 7.x : Создание списка всех видов расчетов

Для включения всех видов расчетов в произвольный список значений без использования перебора групп видов расчетов можно использовать функцию Шаблон().

Код 1C v 7.x
 //Функция присвоения значения
Функция ПолучениеВР(ВР,Объект)
ВР = Объект;
Возврат "";
КонецФункции

//Ниже приведен цикл перебора видов расчетов
сзВидыРасчетов = СоздатьОбъект("СписокЗначений");
Для А = 1 По Метаданные.ВидРасчета() Цикл
текВР = Метаданные.ВидРасчета(А);
Шаблон("[ПолучениеВР(ВР,"+текВР.ПолныйИдентификатор()+")]");
Если ПустаяСтрока(текВР.Синоним) = 1 Тогда
стрВР = текВР.Идентификатор;
Иначе
стрВР = текВР.Синоним;
КонецЕсли;
сзВидыРасчетов.ДобавитьЗначение(ВР,стрВР);
КонецЦикла;
Разместил:   Версии: | 7.x |  Дата:   Прочитано: 4287
 0 
Распечатать
Возможно, вас также заинтересует
Битая ссылка, <Объект не найден>, Уникальный Идентификатор, GUID 21
Когда кто-то удаляет данные из базы без проверки ссылок на эти объекты, то везде где этот объект использовался появляется сообщение вида: Объект не найден (84:bf5600145e3710ab11dda4c605dbe824) . https://helpf.pro/uploads/img/_1-46z7I4U7Ww.png В
Ввод записей в журнал расчетов 0
Добавление записи в журнал расчетов: Метод Новая может быть вызван где угодно, в глобальном модуле, модуле обработок, документов и т.д. Данный метод проверяет корректность заполненных реквизитов журнала расчетов....
Вхождение вида расчета в группу 0
Посчитаем все начисления текущего сотрудника за январь: // 1-й вариант: ВсегоНачислено = 0; ЖЗ.ВыбратьЗаписиПоОбъекту (ТекСотр, ДатаНач, ДатаКон); Пока ЖЗ.ПолучитьЗапись()=1 Цикл Если...
Вывести вид и представление вида Журнала Расчетов Зарплата 0
жз = СоздатьОбъект(" ЖурналРасчетов.Зарплата" ); // Идентификатор ЖЗ Сообщить(жз.Вид()); // Зарплата_2 // Синоним ЖЗ Сообщить(жз.ПредставлениеВида()); // Журнал заработной платы
Вывести все виды субконто, прикрепленные к заданному счету? 0
Для ведения аналитического учета в 1С используется термин “субконто”. Субконто в системе 1С:Предприятие называется объект аналитического учета. Термином «субконто» могут быть обозначены любые объекты...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.