helpf.pro
Регистрация
 0 
Распечатать

1С 7.x : Печать документа в Word используя шаблон doc.dot

Код 1C v 7.x
 
Процедура ПечатьВWord()
wrd=создатьобъект("word.application");
wrd.documents.add("D:\doc.dot");
wrd.visible=1;
wrd.documents(1).tables(1).cell(1,2).range.text = НомерДок;
wrd.documents(1).tables(1).cell(1,4).range.text = ДатаДок;
wrd.documents(1).tables(1).cell(2,2).range.text = Склад.Наименование;
wrd.documents(1).tables(1).cell(3,2).range.text = Получатель.Наименование;
ВыбратьСтроки();
n=КоличествоСтрок() ;
Для i=1 по n-1 Цикл
wrd.documents(1).tables(2).rows.add(wrd.documents(1).tables(2).rows(2).range)
КонецЦикла;
стр = 2;
Пока ПолучитьСтроку()=1 Цикл
wrd.documents(1).tables(2).cell(стр,1).range.text = НомерСтроки;
wrd.documents(1).tables(2).cell(стр,2).range.text =Строка(Товар);
wrd.documents(1).tables(2).cell(стр,4).range.text =Строка(Цена);
wrd.documents(1).tables(2).cell(стр,3).range.text =Строка(Количество);
wrd.documents(1).tables(2).cell(стр,5).range.text =Строка(Сумма);
стр=стр+1;
КонецЦикла;
СуммаДокумента = Итог("Сумма");
wrd.documents(1).tables(2).cell(стр,5).range.text =Строка(СуммаДокумента);
КонецПроцедуры
Разместил:   Версии: | 7.x |  Дата:   Прочитано: 7403
 0 
Распечатать
Возможно, вас также заинтересует
Быстрый перенос списка баз с одного компьютера на другой 0
Для 8.1 : 1. Список баз 8.1 можно сохранять в файл.Для этого правой кнопкой мыши по корневому элементу " Информационные базы " , далее " Сохранить ссылку в файл " . 2. Получаем файл с расширением v8i , это текстовый файл в...
Вывести список элементов справочника в Word используя шаблон spisok.dot 0
Процедура ВывестиСписокЭлементовСправочникаВWord() спр1=создатьобъект(" справочник.сотрудники" ); спр1.ИспользоватьДату(ТекущаяДата()); Сообщить( спр1.НайтиПоНаименованию(" Администрация" ,0,1)); ...
Выгрузка метаданных конфигурации в Microsoft Word и Excel 0
Перем ОбъектыКонфы; Перем СтруктКонфы; Процедура ВыгрузитьВWord() Попытка Word = Новый COMОбъект(" Word.Application" ); Исключение Сообщить(" Не удалось открыть Word" ); Возврат; КонецПопытки; Word.Documents.Add(); Документ = Word.Activ
Запуск макроса в MS Word из 1С 0
//Пример показывает как из 1С вызывается MS Word, вставляется макрос и запускается! //Макрос пишет на листе Добрый день!, http://helpf.pro и сохраняет файл в D:/primer.doc ПримерМакроса = " Sub VBAprimer() |S_election.TypeText Text:=" " Добрый д
Как вывести всплывающее сообщение пользователю? 1
В 8.2 нужно воспользоваться функцией ПоказатьОповещениеПользователя ПоказатьОповещениеПользователя(" Документ не записан!" , " http://doc.ru" , " О правилах заполнения документа, читайте здесь!" , БиблиотекаКартинок.Важно);...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.