helpf.pro
Регистрация
 0 
Распечатать

1С 7.x : Запись движений в оборотный регистр

Методы доступны только при проведении документа в предопределенной процедуре ОбработкаПроведения.
Метод Движение - Выполнить запись движения в оборотный регистр по параметрам.
Код 1C v 7.x
 
Регистр.Товары.Движение (ПоступившийТовар, ТекСклад, КолвоПоНакладной, СуммаПоНакладной)

Код 1C v 7.x
 
Процедура ОбработкаПроведения();
ВыбратьСтроки();
Пока ПолучитьСтроку() > 0 Цикл
Регистр.ОборотыТоваров.Движение(Товар, Склад, ОборотТовара);
КонецЦикла;
КонецПроцедуры


Метод ДвижениеВыполнить - Выполнить запись движения в оборотный регистр по атрибутам.
Код 1C v 7.x
  Процедура ОбработкаПроведения();
Регистр.ТовЗап.Склад = Склад;
ВыбратьСтроки();
Пока (ПолучитьСтроку() > 0) Цикл
Регистр.ТовЗап.Товар = Товар;
Регистр.ТовЗап.Оборот = Оборот;
Регистр.ТовЗап.ДвижениеВыполнить();
КонецЦикла;
КонецПроцедуры;


Примечание: Если сумма или количество в движении будет отрицательным, то это движение будет расходом, иначе приходом.
Разместил:   Версии: | 7.x |  Дата:   Прочитано: 6427
 0 
Распечатать
Возможно, вас также заинтересует
Ввод записей в журнал расчетов 0
Добавление записи в журнал расчетов: Метод Новая может быть вызван где угодно, в глобальном модуле, модуле обработок, документов и т.д. Данный метод проверяет корректность заполненных реквизитов журнала расчетов....
Вхождение вида расчета в группу 0
Посчитаем все начисления текущего сотрудника за январь: // 1-й вариант: ВсегоНачислено = 0; ЖЗ.ВыбратьЗаписиПоОбъекту (ТекСотр, ДатаНач, ДатаКон); Пока ЖЗ.ПолучитьЗапись()=1 Цикл Если...
Выгрузка / Загрузка данных посредством DBF файлов? 1
DBF-файл – это файл, в котором данные хранятся в виде таблицы (Database format). Работа с этими файлами происходит по принципу курсора, т.е. по одной строке. Для работы с DBF-файлами существует тип данных XBase. Несмотря на то, что...
Выгрузка / Загрузка данных посредством XML файлов? 0
В основе работы с XML-файлами лежит технология доступа SAX, которая осуществляет считывание по одному тегу. Для этого существует два типа данных – ЗаписьXML и ЧтениеXML . Запись данных справочника в XML-файл: Запись = Новый...
Выгрузка / Загрузка данных посредством текстовых (TXT) файлов 2
Для работы с текстовыми документами существуют три типа данных – ТекстовыйДокумент, ЗаписьТекста и ЧтениеТекста . Разница двух подходов состоит в способе загрузки документа: ТекстовыйДокумент загружает файл...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.