helpf.pro
Регистрация
 0 
Распечатать

1С 7.x : Выборка документа по номеру и вывод на Печать, в Табличный Документ

Код 1C v 7.x
 
Процедура Печать()
Если (ПустоеЗначение(ДатаНач)=1) или (ПустоеЗначение(ДатаКон)=1) Тогда
Предупреждение("Не задан период отчета");
Возврат;
КонецЕсли;
Заг="За период с "+ДатаНач+" по "+ДатаКон;
Таб=СоздатьОбъект("Таблица");
Таб.ВывестиСекцию("Шапка");
Док=СоздатьОбъект("Документ");
Док.ВыбратьДокументы(ДатаНач,ДатаКон);
ИтогоПриход=0;
ИтогоРасход=0;
Чеков=0;
//1C-ovec.ru Нужно выводить документы по Номеру, хотя лучше для этих целей использовать Запрос
ТЗврем = СоздатьОбъект("ТаблицаЗначений");
ТЗврем.НоваяКолонка("Док");
ТЗврем.НоваяКолонка("Дата");
ТЗврем.НоваяКолонка("Номер");
ТЗврем.НоваяКолонка("Приход");
ТЗврем.НоваяКолонка("Расход");
ТЗврем.НоваяКолонка("Чеков");
//Выборка документов
Пока Док.ПолучитьДокумент()=1 Цикл
Если Док.Проведен()=0 Тогда
Продолжить;
ИначеЕсли (Док.Вид()="ПриходныйОрдерТБ") и (флПКО=1) Тогда
Приход=Док.Сумма;
Расход=0;
ИначеЕсли (Док.Вид()="БезналичнаяОплата") и (флБН=1) Тогда
Приход=Док.Сумма;
Расход=0;
ИначеЕсли (Док.Вид()="РасходныйОрдерТБ") и (флРКО=1) Тогда
Приход=0;
Расход=Док.Сумма;
ИначеЕсли Док.Вид()="Чек" Тогда
Если (Док.Тип=1) и (флЧекиП=1) Тогда
Приход=Док.Сумма;
Расход=0;
Чеков=Чеков+1;
ИначеЕсли (Док.Тип=2) и (флЧекиВ=1) Тогда
Приход=0;
Расход=Док.Сумма;
Чеков=Чеков+1;
Иначе
Продолжить;
КонецЕсли;
Иначе
Продолжить;
КонецЕсли;
//Добавим в ТЗ строку
НовСТР=ТЗврем.НоваяСтрока();
ТЗврем.Док = Док;
ТЗврем.Дата = Док.ДатаДок;
ТЗврем.Номер = Док.НомерДок;
ТЗврем.Приход = Приход;
ТЗврем.Расход =Расход;
ТЗврем.Чеков = Чеков;
//Пока рано выводить
//Таб.ВывестиСекцию("Строка");
ИтогоПриход=ИтогоПриход+Приход;
ИтогоРасход=ИтогоРасход+Расход;
КонецЦикла;
//Теперь сортируем по номеру и выводим
ТЗврем.Сортировать("Номер");
ТЗврем.ВыбратьСтроки();
Пока ТЗврем.ПолучитьСтроку() = 1 Цикл
Док=ТЗврем.Док;
Приход=ТЗврем.Приход;
Расход=ТЗврем.Расход;
Таб.ВывестиСекцию("Строка");
КонецЦикла;

Таб.ВывестиСекцию("Итого");
Таб.ТолькоПросмотр(1);
Таб.Показать("Отчет по кассе");
КонецПроцедуры
Разместил:   Версии: | 7.x |  Дата:   Прочитано: 7306
 0 
Распечатать
Возможно, вас также заинтересует
COM-подключение к базе 7.7 из 8.2 1С 4
Если код выполняется на стороне клиента, то необходимо наличие базы 7.7 на локальной машине. Пример (На форме объекта присутствует реквизит Таблица(ТаблицаЗначений)): НаКлиенте Процедура Загрузки() ПутьКБазе="...
Автоматическая установка ширины колонки табличного документа. 0
Процедура, которая " примерно" делает автоширину колонок (навроде, как если бы выделить все колонки и дважды щелкнуть мышкой по границе заголовка колонки). Привожу текст, работает неахти, но лучше чем ничего: Процедура...
Альтернативный перенос остатков между 7.7 и 8.1 (обработкой с ИТС ЗагрузкаДанныхИзТаблДокум) 0
Нашел альтернативный, практически моментальный способ переноса остатков между семерой и восьмерой (так и между восмерками). Не требуется никаких дополнительных усилий, программирования, писания обработок и т.д. и т.п....
Битая ссылка, <Объект не найден>, Уникальный Идентификатор, GUID 21
Когда кто-то удаляет данные из базы без проверки ссылок на эти объекты, то везде где этот объект использовался появляется сообщение вида: Объект не найден (84:bf5600145e3710ab11dda4c605dbe824) . https://helpf.pro/uploads/img/_1-46z7I4U7Ww.png В
Ввести значение, ввод значения 0
//Пример универсального ввода значения Перем ВыбЗнач; Массив = Новый Массив; Массив.Добавить(Тип("Число")); Массив.Добавить(Тип("Строка")); Массив.Добавить(Тип("Дата")); КЧ = Новый КвалификаторыЧисла(12,2); КС = Новый...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.