helpf.pro
Регистрация
 +4 
Распечатать

1С 7.x : Открыть диалог выбора файла

Код 1C v 8.х
  //На форме есть поле (Путь к файлу), для кнопки Выбор (Событие начало выбора) пропишем процедуру выбора файла
Процедура ВыборФайла(Элемент, ВыбранноеЗначение, СтандартнаяОбработка)
СтандартнаяОбработка=ложь;
Диалог = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Открытие);
Диалог.Заголовок = "Выберите файл";
Диалог.ПолноеИмяФайла = "";
Фильтр = "EXE (*.exe)|*.exe";
Диалог.Фильтр = Фильтр;
Диалог.МножественныйВыбор = Ложь;
Диалог.Каталог = "F:\";
Если Диалог.Выбрать() Тогда
Элемент.значение = Диалог.ПолноеИмяФайла;
КонецЕсли;
КонецПроцедуры


Код 1C v 7.x
 ИмяВыбрФайла = "";
ИмяПути=КаталогИБ()+"ProgFile\";
Если ФС.ВыбратьФайл(0, ИмяВыбрФайла, ИмяПути, "Выберите файл запуска программы", "Все файлы (*.*)!*.*", , ) = 1 Тогда
ПутьЗ=СРЕД((ИмяПути + ИмяВыбрФайла),3,80);
КонецЕсли;
Разместил:   Версии: | 7.x | 8.x |  Дата:   Прочитано: 53776
 +4 
Распечатать
Возможно, вас также заинтересует
Microsift Visual C++ Runtime Library Program ...1cv77s.exe abnormal program termination 0
При запуске 1С 7.7 выдает сообщение: Microsift Visual C++ Runtime Library Program C:Program Files1Cv77BIN1cv77s.exe abnormal program termination Вариант 1. Обычно это происходит, когда повреждается файл регистрации. Точнее, когда не дописывает
Битая ссылка, <Объект не найден>, Уникальный Идентификатор, GUID 21
Когда кто-то удаляет данные из базы без проверки ссылок на эти объекты, то везде где этот объект использовался появляется сообщение вида: Объект не найден (84:bf5600145e3710ab11dda4c605dbe824) . https://helpf.pro/uploads/img/_1-46z7I4U7Ww.png В
Быстрая выгрузка отчетов в Excel, наложение Фильта и отображение ярлыка 0
Вместо Таб.Показать() используем глобальную функцию - и отчет показывается сразу в Excel в удобоваримом виде - с форматированием колонок по ширине, автофильтром и ярлычками листов Процедура...
Ввести перечисление, выбор перечисления 1
// В 8-ой версии нет такой фунции, но можно сделать так: ЗначПер=Перечисления.Важность.Средняя; //Установим перечисление предлагаемое выбрать по умолчанию Если ВвестиЗначение(ЗначПер,"Выберите важность:") тогда ...
Вставьте диск ИТС в дисковод и повторите операцию 0
найти строку и закомментировать: // проверка наличия диска ИТС Делт = КодСимв("Z")-КодСимв("A")+1; СтрокаИТС = Инфо.ПроверитьИмяФайла("1"); // Если ПустоеЗначение(СтрокаИТС)=1 Тогда // Сообщить("Вставьте диск ИТС в дисковод и...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.