helpf.pro
Регистрация
 0 
Распечатать

1С 7.x : Получение остатков регистра запросом, с группировкой по продукту и цене

Код 1C v 7.x
  ДатаК=РабочаяДата(); 
Запрос=СоздатьОбъект("Запрос");
ТекстЗапроса=
"//{{ЗАПРОС(ОстаткиТоваров)
|Период с '01.01.1990' по ДатаК;
|Продукт=Регистр.ПродОст.Продукция;
|Цена=Регистр.ПродОст.Цена;
|Колво=Регистр.ПродОст.Количество;
|Вес=Регистр.ПродОст.Вес;
|Функция КолвоНачОст=НачОст(КолВо);
|Функция КолвоПриход=Приход(КолВо);
|Функция КолвоРасход=Расход(КолВо);
|Функция КолвоКонОст=КонОст(КолВо);
|Функция ВесНачОст=НачОст(Вес);
|Функция ВесПриход=Приход(Вес);
|Функция ВесРасход=Расход(Вес);
|Функция ВесКонОст=КонОст(Вес);
|Группировка Продукт;
|Группировка Цена;
|"//}}ЗАПРОС
;
Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
Возврат;
КонецЕсли;
Сообщить("1");
//... код вывода
Пока Запрос.Группировка("Продукт") = 1 Цикл
Сообщить("2");
//... код вывода
Пока Запрос.Группировка("Продукт") = 1 Цикл
Сообщить("3");
//... код вывода
КонецЦикла;
КонецЦикла;
Сообщить("4");
//... код вывода
Разместил:   Версии: | 7.x |  Дата:   Прочитано: 5053
 0 
Распечатать
Возможно, вас также заинтересует
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.