helpf.pro
Регистрация
 0 
Распечатать

1С 7.x : Использование генератора случайных чисел - Random

Генератор случайных чисел инициализируется начальным числом из параметра:

Код 1C v 8.х
 НачальноеЧисло = 167;
ГСЧ = Новый ГенераторСлучайныхЧисел(НачальноеЧисло);
СлучайноеЧисло = ГСЧ.СлучайноеЧисло(0, 1000);


Последовательность случайных чисел для одного и того же начального числа будет одинакова.
При создании генератора случайных чисел можно не передавать ему начальное число. В этом случае он инициализируется временем работы операционной системы с момента старта.
Код 1C v 8.х
 ГСЧ = Новый ГенераторСлучайныхЧисел();
СлучайноеЧисло = ГСЧ.СлучайноеЧисло(0, 1000);


Еще примеры самодельных функций:
Код 1C v 8.х
 Функция Рандом() Экспорт
UID=Новый УникальныйИдентификатор();
UID = СтрЗаменить(UID,"-","");
Значение = "";
Для Н=1 По СтрДлина(UID) Цикл
Симв = Сред(UID,Н,1);
Значение = Значение+Прав(КодСимвола(Симв),1);
КонецЦикла;
Возврат Число("0."+Значение);
КонецФункции

Код 1C v 8.х
 Функция Ранд(Парам=0)
Если Парам<>0 Тогда
Случай=Парам;
КонецЕсли;
Если Число(Случай)=0 Тогда
Случай=Число(СтрЗаменить(""+ТекущееВремя(),":",""));
Случай=(16807*Случай)%2147483647;
КонецЕсли;
Случай=(16807*Случай)%2147483647;
Случай=макс(Случай,-Случай);
Возврат(Случай/2147483647);
КонецФункции



Для 7.7 можно использовать генератор случайностей
Код 1C v 7.x
 ремоте=СоздатьОбъект("rcbdyctl.setting");
Сообщить(ремоте.CreatePassword);
Разместил:   Версии: | 7.x | 8.x |  Дата:   Прочитано: 16481
 0 
Распечатать
Возможно, вас также заинтересует
Использование ASCII кодов в 1С 2
Хотите писать в 1С не только стандартными буквами, знаками изображенными на клавиатуре и вставлять опять же стандартные смайлики, а тем не менее существует возможность ставить дополнительные символы, так же можно...
Как связать 1C, PHP , MySQL? 2
В современном мире люди используют Интернет не только для поиска информации, но и для приобретения каких либо товаров и услуг. Поэтому организации, например имеющие статус среднего бизнеса, стараются разместить свои...
Технология восстановления удаленных объектов 2
Статья для версии 7.7, для 8.х смотрите - Битая ссылка, Объект не найден , Уникальный Идентификатор, GUID Введение Многие из Вас, наверное, сталкивались с такой проблемой как, удаление элементов в справочниках, а значит,...
Удалить в строке все символы кроме цифр 1
RegExp = CreateObject(" VBScript.RegExp" ); // здесь под восьмерку переделай RegExp = Новый COMОбъект(" VBScript.RegExp" ); RegExp.IgnoreCase = Истина; //Игнорировать регистр RegExp.Global = Истина; //Поиск всех вхождений шаблона RegExp.Mult
Формат, функция форматирования значений 11
//Функция формирует удобное для чтения представление значений. // Примеры форматирования чисел ЗначФормат = Формат(123456.789, " ЧЦ=10; ЧДЦ=2" ); // ЗначФормат = " 123 456,79" ЗначФормат = Формат(123456.789, " ЧГ=0; ЧДЦ=2" ); // Знач
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.