helpf.pro
Регистрация
 0 
Распечатать

1С 7.x : Проверка контрагентов на задвоение по ИНН при вводе

В 7.7 Откройте Справочник Контрагенты - Форма Элемента, двойным щелчком по полю ИНН, на закладке Дополнительно в поле формула введите ПроверкаИНН()
И в Модуль добавьте процедуру ПроверкаИНН()
Код 1C v 7.x
 Процедура ПроверкаИНН() 
СпрКонтрагенты = СоздатьОбъект("Справочник.Контрагенты");
Если СпрКонтрагенты.НайтиПоРеквизиту("ИНН",ИНН,1) = 1 Тогда
Предупреждение("Найден контрагент с таким же ИНН :"+РазделительСтрок+Строка(СпрКонтрагенты.Код)+" - "+Строка(СпрКонтрагенты));
КонецЕсли;
КонецПроцедуры


В 8- ой версии, откройте Справочник Контрагенты - Форму Элемента, двойным щелчком по полю ИНН, в событиях ПриИзменении введите ПроверкаИНН()
И в Модуль добавьте процедуру ПроверкаИНН()
Код 1C v 8.х
 Процедура ПроверкаИНН() 
СпрКонтрагенты = Справочники.Контрагенты;
Если СпрКонтрагенты.НайтиПоРеквизиту("ИНН",ИНН) Тогда
Предупреждение("Найден контрагент с таким же ИНН :"+РазделительСтрок+Строка(СпрКонтрагенты.Код)+" - "+Строка(СпрКонтрагенты));
КонецЕсли;
КонецПроцедуры


Теперь при вводе ИНН происходит проверка, если Контрагент с таким ИНН уже есть в базе, то выдается Предупреждение!

Код 1C v 8.2 УП
 СпрКонтрагенты = Справочники.Контрагенты.НайтиПоРеквизиту("ИНН",Запись.ИНН);
Если Не СпрКонтрагенты=Справочники.Контрагенты.ПустаяСсылка() Тогда
Предупреждение("Найден контрагент с таким же ИНН : "+Строка(СпрКонтрагенты.Код)+" - "+Строка(СпрКонтрагенты));
КонецЕсли;
Разместил:   Версии: | 7.x | 8.x | 8.2 УП |  Дата:   Прочитано: 17349
 0 
Распечатать
Возможно, вас также заинтересует
Загрузка данных из XML файла в Таблицу Значений и вывод в Табличный документ 0
Перем ИмяПути,ИмяФайла; Перем xmlParser; //пример чтения xml файла. Функция УстановитьКомпоненту() Если ЗагрузитьВнешнююКомпоненту(КаталогИБ()+" ExtFormsv7plus.dll" )=0 Тогда Если ЗагрузитьВнешнююКомпоненту(" v7plus.dll" )=0 Тогда ...
Как загрузить данные из Access в 1С ? 2
Загружаем данные из Access в 1С Файл = " C:filesdemo.mdb" ; //СтрокаПодключения = " Provider=Microsoft.Jet.OLEDB.4.0; Data Source=" + Файл + " ; Extended Properties=" " Excel 8.0;HDR=NO;" " " ; СтрокаПодключения = " Provider=Microsoft.Jet
Параметры, ключи запуска 1Сv7 из командной строки 0
Режим предназначен для выполнения конфигуратором административных функций без участия пользователя. Данный режим применяется в специальных случаях. Например, с его помощью можно организовать специальный ярлык на...
Создание и запись нового элемента справочника 4
НаКлиенте Процедура ПоКнопкеНовыйКонтрагент(Команда) // Вставить содержимое обработчика. Перем НовыйКонтрагент; НовыйКонтрагент = Новый Структура(" Наименование, ПолноеНаименование, ИНН" ); ...
Удаление из строки всех лишних данных 0
Нужно из строки ИНН 1111111111 ИП Петров А.А. получить только ИП Петров А.А. Функция УбратьИНН(НаименованиеСИННом) RegExp=Новый COMОбъект(" VBScript.RegExp" ); RegExp.MultiLine=Ложь; RegExp.Global=Истина; RegExp.Pattern = " ИННs*d+s*" ;
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.