helpf.pro
Регистрация
 0 
Распечатать

1С 7.x : Экспорт печатных форм и любых данных из 1С в BMP, JPEG, PCX, PDF, PNG и TIFF.

Оптимальным решением является установка Bullzip PDF Printer . После установки в системе появляется виртуальный принтер, с помощью которого можно "печатать" в файл pdf из любого приложения. Программа бесплатная, работает в терминале и имеет поддержку русского языка.
После установки, можно печатать напрямую используя код:
Код 1C v 8.х
 
//Таб - ТабличныйДокумент
//ИмяФайла – путь для сохранения файла PDF (например «D:\Torg12.pdf»)
Процедура СоздатьФайлПДФ(Таб, ИмяФайла)

Попытка
ПДФПринтер = Новый ComObject(«Bullzip.PDFPrinterSettings»);
ПДФПринтер.SetValue(«output», ИмяФайла);
ПДФПринтер.SetValue(«ShowSaveAS», «never»);
ПДФПринтер.SetValue(«ShowProgress», «no»);
ПДФПринтер.SetValue(«ShowProgressFinished», «no»);
ПДФПринтер.SetValue(«ShowSettings», «never»);
ПДФПринтер.SetValue(«ShowPDF», «no»);
ПДФПринтер.SetValue(«ConfirmOverwrite»,»no»);
ПДФПринтер.WriteSettings();
Таб.Автомасштаб = Истина;
Таб.ИмяПринтера = «Bullzip PDF Printer»;Таб.Напечатать(Истина);
PDFФайл = Новый Файл(ИмяФайла);

Пока НЕ PDFФайл.Существует() Цикл
ОбработкаПрерыванияПользователя();
КонецЦикла;

Исключение

Сообщить(ОписаниеОшибки());
Сообщить(«Скорее всего необходимо установить или переустановить «»Bullzip PDF Printer»);
КонецПопытки;
//устанавливаем принтер по умолчанию
Таб.ИмяПринтера = ПолучитьПринтерПоУмолчанию();
КонецПроцедуры

Здесь функция ПолучитьПринтерПоУмолчанию() нужна для того чтобы вернуть печатной форме принтер по умолчанию, т.к. если напечатать без предварительного просмотра то печать пойдет на виртуальный PDF принтер BullzipPDFPrinter.
Код 1C v 8.х
 //получаем принтер по умолчанию
Функция ПолучитьПринтерПоУмолчанию()

Скрипт = Новый ComObject(«MSScriptControl.ScriptControl»);
Скрипт.Language = «vbscript»;
Скрипт.AddCode(»
|Function GetDefaultPrinter()
|GetDefaultPrinter=vbNullString
|Set objWMIService=GetObject(«»winmgmts:»" _
|& «»{impersonationLevel=impersonate}!\\.\root\cimv2″»)
|Set colInstalledPrinters=objWMIService.ExecQuery _
|(«»S_elect * from Win32_Printer»")
|For Each objPrinter in colInstalledPrinters
|If objPrinter.Attributes and 4 Then
|GetDefaultPrinter=objPrinter.Name
|Exit For
|End If
|Next
|End Function»);
Возврат СокрЛП(Скрипт.run(«GetDefaultPrinter»));
КонецФункции



Печать в PDF используя bioPDF
Разместил:   Версии: | 7.x | 8.x | 8.2 УП |  Дата:   Прочитано: 23964
 0 
Распечатать
Возможно, вас также заинтересует
Не работает предварительный просмотр документа в 1С 0
Варианты решения проблемы " Не открывается предварительный просмотр" : 1. Нет принтера - нет предварительного просмотра. Попробуй переустановить принтеры. 2. Поставил под локальным админом дрова на принтер как у...
Получить имя принтера выбранного по умолчанию 0
// maharbA Функция Hex(Пар) Результат=" " ; Пока Пар 0 Цикл Результат=Сред(" 0123456789ABCDEF" ,Пар+1,1)+Результат; Пар=Цел(Пар/16) ; КонецЦикла; Возврат " " +Результат; КонецФункции Функция ПолучитьПринтерПоУмолчанию() ...
Установить штрихкод в 1С 1
В программах 1С Предприятие применяется несколько разных вариантов штрихкодов 1. Штрихкод в регламентированных отчетах Расположен в левом верхнем углу налоговой декларации. Для печати используется установленный...
Установка модуля печати двухмерного штрих-кода PDF417 в 1С 0
Двумерные штрих-коды – символики, разработанные для кодирования большого объема информации (до нескольких страниц текста). Такой код считывается с помощью специального сканера и позволяет быстро и безошибочно...
Функция открывает таблицу в MS Excel 0
Код //Функция открывает таблицу в MS Excel //Таблица - печатная форма 1С //ИмяЛиста - имя, которое будет присвоено листу книги MS Excel (если не задано, то остается " Sheet1" ) //ОтображатьЯрлычки - показывать/скрыть ярлычки...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.