helpf.pro
Регистрация
 0 
Распечатать

1С 7.x : Перебор Основных Реквизитов формы

Код 1C v 8.х
 //Перебор Основных Реквизитов формы
Для Каждого Рек из ЭтаФорма.Метаданные().Реквизиты Цикл
Сообщить(рек.Имя+" - "+рек.Синоним+" - "+Строка(рек.Тип));
КонецЦикла;
// или так
Для Каждого Рек из Метаданные().Реквизиты Цикл
Сообщить(рек.Имя+" - "+рек.Синоним+" - "+Строка(рек.Тип));
КонецЦикла;

//Реквизиты формы - Надписи, Поля Ввода и т.д
//можно и через ЭтаФорма.ЭлементыФормы
Для Каждого Рек из ЭлементыФормы Цикл
Сообщить(Строка(рек)+" - "+рек.имя);
КонецЦикла;


Код 1C v 7.x
  //функция создаёт список реквизитов документа
Процедура гСписокРеквизитовДокумента(Список,Документ,ФлагПредставление=0) Экспорт
//Шапка
Для i=1 По Метаданные.Документ(Документ).РеквизитШапки() Цикл
Ж=Метаданные.Документ(Документ).РеквизитШапки(i);
Если ФлагПредставление=0 Тогда
Представление=Ж.Идентификатор;
Иначе
Представление=Ж.Представление();
КонецЕсли;
Список.ДобавитьЗначение(Ж.Идентификатор,"Ш: "+Представление);
КонецЦикла;
//Табличная часть
Для i=1 По Метаданные.Документ(Документ).РеквизитТабличнойЧасти() Цикл
Ж=Метаданные.Документ(Документ).РеквизитТабличнойЧасти(i);
Если ФлагПредставление=0 Тогда
Представление=Ж.Идентификатор;
Иначе
Представление=Ж.Представление();
КонецЕсли;
Список.ДобавитьЗначение(Ж.Идентификатор,"Т: "+Представление);
КонецЦикла;
//Общие
Для i=1 По Метаданные.ОбщийРеквизитДокумента() Цикл
Ж=Метаданные.ОбщийРеквизитДокумента(i);
Если ФлагПредставление=0 Тогда
Представление=Ж.Идентификатор;
Иначе
Представление=Ж.Представление();
КонецЕсли;
Список.ДобавитьЗначение(Ж.Идентификатор,"О: "+Представление);
КонецЦикла;
КонецПроцедуры
Разместил:   Версии: | 7.x | 8.x |  Дата:   Прочитано: 13401
 0 
Распечатать
Возможно, вас также заинтересует
1С Предприятие что это? 6
Что такое 1С? 1С — это фирма , у которой одно из направлений деятельности — разработка программного обеспечения для автоматизации бизнес-процессов предприятий. « 1С:Предприятие » - конкретный продукт, который...
Ввод записей в журнал расчетов 0
Добавление записи в журнал расчетов: Метод Новая может быть вызван где угодно, в глобальном модуле, модуле обработок, документов и т.д. Данный метод проверяет корректность заполненных реквизитов журнала расчетов....
Вывод (печать) таблицы значений в табличный документ 4
Пример кода быстрая Печать таблицы значений //ТПОтчета - Табличное поле с формы (Таблица значений) с данными ПострПечать = Новый ПостроительОтчета; ПострПечать.ИсточникДанных = Новый...
Выгрузка / Загрузка данных посредством текстовых (TXT) файлов 2
Для работы с текстовыми документами существуют три типа данных – ТекстовыйДокумент, ЗаписьТекста и ЧтениеТекста . Разница двух подходов состоит в способе загрузки документа: ТекстовыйДокумент загружает файл...
Выгрузка данных в Excel с установкой разных параметров 4
// Процедура выгружает из указанного справочника данные в режиме экспорта в файл в формате Microsoft Excel // с указанным именем, используя преобразование данных к типу число и типу строка; Процедура...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.