helpf.pro
Регистрация
 0 
Распечатать

1С 7.x : Загрузка данных из DBF файла в Таблицу Значений

Код 1C v 7.x
  Процедура ПоказатьДБФ(дбф, имяФайла) далее

Процедура Сформировать()
перем дбф, флаг, папка;
тЗнач.Очистить();
флаг=ФС.ВыбратьФайл(0, имяФайла, папка,"Выберете DBF файл","|*.DBF");
Если флаг=0 Тогда
возврат;
КонецЕсли;
дбф=СоздатьОбъект("Xbase");
дбф.ОткрытьФайл(папка+имяФайла);
папк=папка;
файл=имяФайла;
Если дбф.открыта()=0 Тогда
Предупреждение("Не могу открыть файл"+имяФайла);
возврат;
КонецЕсли;
ПоказатьДБФ(дбф, имяФайла);
КонецПроцедуры

Процедура ПоказатьДБФ(дбф, имяФайла)
Перем ин, имяПоля, тип, длина, точность, номСтроки;
для ин=1 по дбф.КоличествоПолей() цикл
дбф.ОписаниеПоля(ин, имяПоля, тип, длина, точность);
тЗнач.НоваяКолонка(имяПоля, тип);
тЗнач.УстановитьПараметрыКолонки(ин, тип, длина, точность,, мин(10, длина));
конецЦикла;

КолП=дбф.КоличествоПолей();
НомС=ДБФ.КоличествоЗаписей();

загТЗнач="Файл "+имяФайла;
дбф.Первая();
номСтроки=0;
Пока дбф.ВКонце()=0 Цикл
номСтроки=номСтроки+1;
тЗнач.НоваяСтрока(номСтроки);
для ин=1 по дбф.КоличествоПолей() цикл
тЗнач.УстановитьЗначение(номСтроки, ин, дбф.ПолучитьЗначениеПоля(ин));
КонецЦикла;
дбф.Следующая();
конецЦикла;
КонецПроцедуры
Разместил:   Версии: | 7.x |  Дата:   Прочитано: 12014
 0 
Распечатать
Возможно, вас также заинтересует
1С 7.x : Как получить курсы валют с сайта НБУ http://www.bank.gov.ua/ за любую дату ? 2
Функция ПолучитьТаблицуКурсовНБУ(ДатаКурса, Ежедневно = 1) // если в качестве второго параметра указать число отличное от 1 - получем валюты, которые котируются на ежемесячной основе Перем Reader, Url, Точки, HtmlTab, Строк, Р,...
COM-подключение к базе 7.7 из 8.2 1С 4
Если код выполняется на стороне клиента, то необходимо наличие базы 7.7 на локальной машине. Пример (На форме объекта присутствует реквизит Таблица(ТаблицаЗначений)): НаКлиенте Процедура Загрузки() ПутьКБазе="...
Автоматическая установка ширины колонки табличного документа. 0
Процедура, которая " примерно" делает автоширину колонок (навроде, как если бы выделить все колонки и дважды щелкнуть мышкой по границе заголовка колонки). Привожу текст, работает неахти, но лучше чем ничего: Процедура...
Битая ссылка, <Объект не найден>, Уникальный Идентификатор, GUID 21
Когда кто-то удаляет данные из базы без проверки ссылок на эти объекты, то везде где этот объект использовался появляется сообщение вида: Объект не найден (84:bf5600145e3710ab11dda4c605dbe824) . https://helpf.pro/uploads/img/_1-46z7I4U7Ww.png В
Выбор оптимального алгоритма для разбора строки в массив 0
Столкнулся с проблемой: ПолучитьСтрокуПоНомеру() медленно отрабатывает на входных данных 100 000 строк. Как сделать бытсрее? // Пример Defender aka LINN ВремяНачала = ТекущаяДата(); Сообщить(" Обработка начата: " + ВремяНачала); ...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.