helpf.pro
Регистрация
 0 
Распечатать

1С 7.x : Поиск в DBF файле по индексу

Код 1C v 7.x
  ДБФ=СоздатьОбъект("XBase");
ДБФ.ДобавитьПоле("DATE","D",0,0);
Дбф.ДобавитьИндекс("INDEX","DTOS(DATE)",0,0,"<");
//Дбф.ДобавитьИндекс("INDEX","DTOS(DATE)",0,0,"Пустая строка"); //DTOS !!!
// где DTOC() - "ММ/ДД/ГГ" или DTOS() - "ГГГГММДД"
ДБФ.СоздатьФайл("c:\test.dbf","c:\test.cdx");
Для ТекДата='01.09.05' По '10.09.05' Цикл
Дбф.Добавить();
Дбф.DATE=ТекДата;
ДБФ.Записать();
КонецЦикла;
//ДБФ.КодоваяСтраница(0);
ДБФ.ТекущийИндекс("INDEX");
Для ТекДата='01.09.05' По '10.09.05' Цикл
ДБФ.Ключ.DATE = ТекДата;
Если ДБФ.НайтиПоКлючу(0)=1 Тогда
Сообщить(ТекДата);
КонецЕсли;
КонецЦикла;
ДБФ.ЗакрытьФайл();
Разместил:   Версии: | 7.x |  Дата:   Прочитано: 7382
 0 
Распечатать
Возможно, вас также заинтересует
Быстрый перенос списка баз с одного компьютера на другой 0
Для 8.1 : 1. Список баз 8.1 можно сохранять в файл.Для этого правой кнопкой мыши по корневому элементу " Информационные базы " , далее " Сохранить ссылку в файл " . 2. Получаем файл с расширением v8i , это текстовый файл в...
Выгрузка / Загрузка данных посредством DBF файлов? 1
DBF-файл – это файл, в котором данные хранятся в виде таблицы (Database format). Работа с этими файлами происходит по принципу курсора, т.е. по одной строке. Для работы с DBF-файлами существует тип данных XBase. Несмотря на то, что...
Выгрузка / Загрузка данных посредством текстовых (TXT) файлов 2
Для работы с текстовыми документами существуют три типа данных – ТекстовыйДокумент, ЗаписьТекста и ЧтениеТекста . Разница двух подходов состоит в способе загрузки документа: ТекстовыйДокумент загружает файл...
Журнал регистрации 0
Журнал регистрации относится к информационной базе и служит для сохранения информации о событиях, возникающих в процессе работы пользователей с данной информационной базой . Эта информация может быть важной с...
Как отключить вывод splash заставки 1C предприятия ? 0
Для 1С 7.7: 1. Воспользуйтесь файлом Отключение splash-заставки появляющейся при запуске 1С-Предприятия 7.7 2. При OLE - Нужно поставить NO_SPLASH_SHOW Внимание! - работает это только при запуске в режиме OLE Automation сервера V7 =...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.