helpf.pro
Регистрация
 0 
Распечатать

1С 7.x : Пример создания общего журнала с закладками, для 7.7

Создание журнала с закладками, причем в справочнике можно задать каждой закладке любое название. Создавал в конфигурациях «Бухгалтерский учет» и «Торговля и Склад». Выглядит это так:
title

а справочник:
title

1. Создаем новый справочник.Новый1
где, уровень = 1, длина кода = 10, длина наименования = 50. серии кодов = в пределах подчинения, тип кода = текстовый, основное представление = в виде наименования.
Редактируем форму списка:
Добавляем 2 кнопки: Заполнить, Применить.
В модуль:
Код 1C v 7.x
 Процедура Заполнить()
Спр = СоздатьОбъект("Справочник.Новый1");
Для Х = 1 По Метаданные.Документ() Цикл
ИдДок = Метаданные.Документ(Х).Идентификатор;
Если Спр.НайтиПоНаименованию(ИдДок) = 0 Тогда
Спр.Новый();
Спр.Наименование = ИдДок;
Спр.Записать();
КонецЕсли;
КонецЦикла;
КонецПроцедуры

Процедура Применить()
НачатьТранзакцию();
Спр = СоздатьОбъект("Справочник.Новый1");
Х = 0;
Док = СоздатьОбъект("Документ");
Док.ВыбратьДокументы();
Пока Док.ПолучитьДокумент() = 1 Цикл
ВидДок = Док.Вид();
Если Спр.НайтиПоНаименованию(ВидДок) = 1 Тогда
Док.ДляОтбора = Спр.Код;
Док.Записать();
КонецЕсли;
Х = Х + 1;
Состояние(Х);
КонецЦикла;
ЗафиксироватьТранзакцию();
КонецПроцедуры


2. В Документы, Общие реквезиты добавляем «ДляОтбора» где: Тип значения = строка и длина = 10 , в Дополнительные стоит галочка «Отбор».

3. В «Журналах» копируем «Общий» и в его модуле пишем:
Код 1C v 7.x
 Процедура ПриОткрытии()
ЗакладкиОтбора("ДляОтбора");
КонецПроцедуры //ПриОткрытии


4. Заходим в режиме Предприятия, открываем созданный нами справочник и заполняем его. Называем закладки и жмем «Применить», открываем Журнал и пользуемся )
Разместил:   Версии: | 7.x |  Дата:   Прочитано: 14488
 0 
Распечатать
Возможно, вас также заинтересует
COM-подключение к базе 7.7 из .NET, .NET Core 0
Инсталяция: dotnet add package sabatex.V1C77 или добавить через NUGET пакет sabatex.V1C77. Добавить пространство имен: using sabatex.V1C77; пример использованя: ---C# static void Main(string args) { // создаем строку соединен
COM-подключение к базе 7.7 из 8.2 1С 6
Если код выполняется на стороне клиента, то необходимо наличие базы 7.7 на локальной машине. Пример (На форме объекта присутствует реквизит Таблица(ТаблицаЗначений)): НаКлиенте Процедура Загрузки() ПутьКБазе=" D:ВашаБаза1с77" ; Пользователь=
Cклонения по падежам 6
НаКлиенте Процедура Команда1(Команда) ФИО = " Иванов Иван Иванович" ; Падеж = 2; Пол = 1; Результат = СклонениеФИО(ФИО, Падеж, пол); Сообщить(Результат); КонецПроцедуры НаСервере Функция СклонениеФИО(ФИО, Падеж, пол) Результат = " " ;
Автоматическая установка ширины колонки табличного документа. 0
Процедура, которая " примерно" делает автоширину колонок (навроде, как если бы выделить все колонки и дважды щелкнуть мышкой по границе заголовка колонки). Привожу текст, работает неахти, но лучше чем ничего: Процедура РасчетШириныКолонок(Табличный
Алгоритм шифрования RC4 1
Для решения некоторых задач, иногда требуется имееть возможность шифровать и дешифровывать, какие-то данные. Но при этом нет возможности использовать стороние внешнии компоненты. Предлагаем пример реализации алгоритма шифрования RC4 на встроенном яз
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.