helpf.pro
Регистрация
 0 
Распечатать

1С 7.x : Как получить текущее время с милисекундами?

В Платформе 8.2.17 реализована возможность получения числа миллисекунд, прошедших с 1 января 0001 года, 0:00:00 UTC с помощью функции
Код 1C v 8.2 УП
 ТекущаяУниверсальнаяДатаВМиллисекундах()    


Код 1C v 8.х
  // В 8.х переменные типа "дата" содержат миллисекунды, только это нигде не написано
ДатаИсх = ТекущаяДата(); //простая дата+время
ДатаНов = ДатаИсх + 0.567; //дата+время+миллисекунды
Миллисекунды = (ДатаНов - ДатаИсх) * 1000; //вытаскиваем миллисекунды из даты


Код 1C v 8.х
 Функция ПолучитьТекущееВремяВМиллисекундах() Экспорт
Если JavaScript = Неопределено Тогда
Попытка
JavaScript = Новый COMОбъект("MSScriptControl.ScriptControl");
Исключение
Сообщить(ОписаниеОшибки(), СтатусСообщения.Внимание);
Возврат 0;
КонецПопытки;
JavaScript.Language = "javascript";
КонецЕсли;
Время = JavaScript.Eval("new Date().getTime()");
Возврат Время;
КонецФункции

Код 1C v 8.х
 // Как быстрее получить время в миллисекундах? 
Locator = Новый COMОбъект("WbemScripting.SWbemLocator");
ServicesSet = Locator.ConnectServer(".");
Для а=1 по 100 цикл
pEnum = ServicesSet.InstancesOf("Win32_OperatingSystem");
Для каждого Object Из pEnum Цикл
сообщить(сред(Object.LocalDateTime,13,6));
Прервать;
КонецЦикла;
КонецЦикла;



Код 1C v 7.x
 
Scr=СоздатьОбъект("MSScriptControl.ScriptControl");
Scr.Language = "javascript";
d=Scr.Eval("new Date();");
Сообщить(d.getTime(0));
Сообщить(d.getHours(0));
Сообщить(d.getMinutes(0));
Сообщить(d.getSeconds(0));
Сообщить(d.getMilliseconds(0));
Разместил:   Версии: | 7.x | 8.x | 8.2 УП |  Дата:   Прочитано: 19568
 0 
Распечатать
Возможно, вас также заинтересует
Итог оборотного регистра 0
// Пример 1 Функция ПолучитьИтог(Товар, Склад, Год); Регистр.ОборотыТоваров.ИспользоватьПериод(Год); Возврат Регистр.ОборотыТоваров.Итог(Товар, Склад, " ОборотТовара" ); КонецФункции // Пример 2 ...
Итоги оборотного регистра 0
// Пример 1 Регистр.ОборотыТоваров.ИспользоватьПериод(Год); Регистр.ОборотыТоваров.Итоги(Товар, Склад); ОбТов = Регистр.ОборотыТоваров.ОборотТовара; // Пример 2 РегДоходы = СоздатьОбъект(" Регистр.Доходы" ); ...
Как указать нужную,конкретную дату? 1
Значения данного типа содержит дату григорианского календаря (с 01 января 0001 года) и время с точностью до секунды. Литералы: Строка цифр, заключенная в одинарные кавычки вида: ГГГГММДДччммсс, где: ГГГГ - четыре цифры...
Производственный календарь на 2015 год 0
Производственный календарь & незаменимый помощник бухгалтера и кадровика. В нем содержится информация о количестве рабочих, выходных и праздничных дней, норме рабочего времени в 2015 году. Для удобства использования...
Сводные Итоги оборотного регистра 0
Метод работает аналогично процедуре Итоги, однако здесь могут быть заданы не все значения измерений, а только несколько, но обязательно в правильной последовательности, соответствующей структуре измерений данного...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.