helpf.pro
Регистрация
 0 
Распечатать

1С 7.x : Как получить список реквизитов операции и проводок?

Код 1C v 7.x
  // Пример 1
Для к = 1 по Метаданные.РеквизитПроводки()
Сообщить(Метаданные.РеквизитПроводки(к).Идентификатор);
КонецЦикла;


Код 1C v 7.x
  // Пример 2
СписокРеквизитов = СоздатьОбъект("СписокЗначений");
// реквизиты формы операции
СписокРеквизитов.ДобавитьЗначение("ДатаОперации");
СписокРеквизитов.ДобавитьЗначение("НомерДок");
СписокРеквизитов.ДобавитьЗначение("СуммаОперации");
СписокРеквизитов.ДобавитьЗначение("Содержание");

// Дополнительные реквизиты операции
Для М1 = 1 По Метаданные.РеквизитОперации() Цикл
СписокРеквизитов.ДобавитьЗначение(Метаданные.РеквизитОперации(М1).Идентификатор);
КонецЦикла;

// Общие реквизиты документов
Для М1 = 1 По Метаданные.ОбщийРеквизитДокумента() Цикл
СписокРеквизитов.ДобавитьЗначение(Метаданные.ОбщийРеквизитДокумента(М1).Идентификатор);
КонецЦикла;

СписокРеквизитов.ДобавитьЗначение("НомерПроводки");
СписокРеквизитов.ДобавитьЗначение("ПланСчетов");
СписокРеквизитов.ДобавитьЗначение("СчетДт");
СписокРеквизитов.ДобавитьЗначение("СчетКт");
СписокРеквизитов.ДобавитьЗначение("Субконто");
СписокРеквизитов.ДобавитьЗначение("СубконтоДт");
СписокРеквизитов.ДобавитьЗначение("СубконтоКт");

Для М1 = 1 По Метаданные.МаксимальноеКоличествоСубконто Цикл
СписокРеквизитов.ДобавитьЗначение("Субконто" + М1);
СписокРеквизитов.ДобавитьЗначение("СубконтоКт" + М1);
СписокРеквизитов.ДобавитьЗначение("СубконтоДт" + М1);
КонецЦикла;


СписокРеквизитов.ДобавитьЗначение("Валюта");
СписокРеквизитов.ДобавитьЗначение("Курс");
СписокРеквизитов.ДобавитьЗначение("Количество");
СписокРеквизитов.ДобавитьЗначение("ВалСумма");
СписокРеквизитов.ДобавитьЗначение("Сумма");
СписокРеквизитов.ДобавитьЗначение("НомерСтроки");

// Дополнительные реквизиты проводки
Для М1 = 1 По Метаданные.РеквизитПроводки() Цикл
СписокРеквизитов.ДобавитьЗначение(Метаданные.РеквизитПроводки(М1).Идентификатор);
КонецЦикла;

// журнал операций
СписокРеквизитов.ДобавитьЗначение("ВидДок");
СписокРеквизитов.ДобавитьЗначение("ВремяОперации");

// Дополнительные графы журнала операций
Для М1 = 1 По Метаданные.ГрафаЖурналаОпераций() Цикл
СписокРеквизитов.ДобавитьЗначение(Метаданные.ГрафаЖурналаОпераций(М1).Идентификатор);
КонецЦикла;
Разместил:   Версии: | 7.x |  Дата:   Прочитано: 5539
 0 
Распечатать
Возможно, вас также заинтересует
Как найти существующие ссылки на объекты? 3
Для 8.х НайтиПоСсылкам (FindDataByRef) Синтаксис: НайтиПоСсылкам ( Список ссылок ) Параметры: Список ссылок Обязательный Тип: Массив. Массив со списком ссылок на объекты, ссылки на которые нужно найти. ...
Как установить дату запрета редактирования документов? 0
Для 8.х: Открываете Сервис - Пользователи и права доступа далее Дата запрета редактирования Устанавливаете Дату для всех пользователей или выборочно, указав пользователя. Для 7.7: Открываете Операции - Константы ...
Обработка проведения (создание проводок) 0
Процедура ОбработкаПроведения() Пока ПолучитьСтроку() = 1 Цикл Операция.НоваяПроводка(); Операция.Кредит.Счет = СчетПоКоду(" 60.1" ); Операция.Дебет.Счет = СчетПоКоду(" 08.4" ); Операция.СодержаниеПроводки = " Поступление ОС"...
Операции и проводки 0
Операции, проводки, корреспонденции Для отражения данных о хозяйственной деятельности предприятия в бухгалтерском учете используются операции. Каждая операция содержит одну или несколько проводок. Проводка...
ОС Windows Server не видит больше 4 GB ОЗУ, MS SQL Server не может использовать больше 2 GB. 0
С этой проблемой сталкиваются те, у которых на сервере более 4 GB ОЗУ. Вкратце, для работы с памятью более 4 GB понадобится одна из нижеперечисленных ОС: Windows 2000 Advanced Server, Windows 2000 Datacenter Server, Windows Server 2003 Enterpris
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.