helpf.pro
Регистрация
 +2 
Распечатать

1С 8.x : Как в каталоге получить подкаталоги, а потом в подкаталогах файлы?

Код 1C v 8.х
 Процедура НайтиФайлыПоПодпапкам(НайденныеФайлы, Каталог, Маска)
Если НайденныеФайлы = Неопределено Тогда
НайденныеФайлы = Новый Массив;
КонецЕсли;
Путь = Каталог;
МассивФайлов = НайтиФайлы(Путь, Маска);
Для Каждого НайденныйФайл Из МассивФайлов Цикл
НайденныеФайлы.Добавить(НайденныйФайл);
КонецЦикла;
МассивКаталогов = НайтиФайлы(Путь, "*");
Для Каждого Папка Из МассивКаталогов Цикл
Попытка
Если Папка.ЭтоКаталог() Тогда
НайтиФайлыПоПодпапкам(НайденныеФайлы, Папка.ПолноеИмя, Маска);
КонецЕсли;
Исключение
Сообщить(ОписаниеОшибки());
КонецПопытки;
КонецЦикла;
КонецПроцедуры

а в 8.2 достаточно:
Код 1C v 8.2 УП
 НайденныеФайлы = НайтиФайлы(КаталогПоиска, Маска, Истина);   
Разместил:   Версии: | 8.x | 8.2 УП |  Дата:   Прочитано: 12790
 +2 
Распечатать
Возможно, вас также заинтересует
Excel файл как Внешний источник данных 4
Подключимся и загрузим из файла Excel данные в таблицу значений 1С. Сделать теперь это очень просто. 1. В конфигурации добавляет новый объект метаданных типа " Внешние источники данных" и назовем его просто " Excel" . ...
Google maps : вывод точек на карту и режим панорамы 2
В отличие от яндекс карт в GMaps можно использовать панорамы - за что им большой плюс! Надеюсь в яндексе прочитают этот пост и тоже когда-нибудь это сделают! Для клиента нужно было сделать вывод объектов на карту С...
ZIP-архив Разделить и Объединить Файл 0
При работе с большими объемами данных могут возникнуть проблемы при пересылке архивных файлов. Типичной такой ситуацией является ограничение некоторых почтовых серверов на размер сообщения - если письмо превышает...
ZIP-архив Создание 0
Для того чтобы записать файлы в ZIP-архив необходимо выполнить несколько простых действий: * Создать архив с необходимыми параметрами, в который будут помещаться файлы. * Поместить в архив необходимые файлы. * Записать...
ZIP-архив Чтение 0
Для того чтобы прочитать файлы из ZIP-архива необходимо выполнить несколько простых действий: - Открыть необходимый архив - Распаковать файлы Создание объекта ЧтениеZIPФайла можно осуществить двумя путями - создать...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.