helpf.pro
Регистрация
 0 
Распечатать

1С 8.x : Как программно выполнить задачу БП?

Код 1C v 8.2 УП
 &НаСервере
Процедура ЗафиксироватьВыполнениеНаСервере()

ЗадачаОбъект = Задача.Ссылка.ПолучитьОбъект();

ЗадачаОбъект.ВыполнитьЗадачу();

КонецПроцедуры


Код 1C v 8.х
 ТекстВопроса = "Задача будет завершена. Продолжить?";
ОтветНаВопрос = Вопрос(ТекстВопроса,РежимДиалогаВопрос.ОКОтмена,,КодВозвратаДиалога.ОК);
Если ОтветНаВопрос = КодВозвратаДиалога.ОК Тогда
ВыполнитьЗадачуИнтерактивно();
ЗаписатьВФорме();

// условие для БП Поручение
Если ТипЗнч(БизнесПроцесс) = Тип("БизнесПроцессСсылка.CRM_Поручение")
И (ТочкаМаршрута.Имя = "Контроль")Тогда
БизнесПроцессЗадачи = ЗадачаОбъект.БизнесПроцесс.ПолучитьОбъект();
БизнесПроцессЗадачи.КачествоВыполнения = ЭлементыФормы.Оценка.Значение;
БизнесПроцессЗадачи.Записать();
КонецЕсли;
Закрыть();
КонецЕсли;
Разместил:   Версии: | 8.x | 8.2 УП |  Дата:   Прочитано: 7064
 0 
Распечатать
Возможно, вас также заинтересует
1С Предприятие что это? 6
Что такое 1С? 1С — это фирма , у которой одно из направлений деятельности — разработка программного обеспечения для автоматизации бизнес-процессов предприятий. « 1С:Предприятие » - конкретный продукт, который...
Активация открытой книги Excel для корректировки 0
Нужно было получить для изменения уже открытую книгу Excel, а если она закрыта, то открыть и изменять. Ниже код, который данную задачу решает. Попытка Эксель = Неопределено; Книга = Неопределено; Лист = Неопределено; ...
Ввести перечисление, выбор перечисления 1
// В 8-ой версии нет такой фунции, но можно сделать так: ЗначПер=Перечисления.Важность.Средняя; //Установим перечисление предлагаемое выбрать по умолчанию Если ВвестиЗначение(ЗначПер,"Выберите важность:") тогда ...
Выбор периода, задать период 2

Выгрузка табличного документа в Google таблицу 0
Надумал когда-то задачу себе: выгрузить содержимое табличного документа в Google Document . Одним из вариантов использования данного функционала может быть выгрузка состояния заказов пользователей из базы в 1с в google spreadsheet....
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.