helpf.pro
Регистрация
 0 
Распечатать

1С 8.x : Как определить при добавлении нового справочника, что он добавляется копированием?

Код 1C v 8.х
 // В Процедуре ПриОткрытии()
Если ЭтоНовый() Тогда
Если НЕ ПараметрОбъектКопирования = НЕОПРЕДЕЛЕНО Тогда // Проверка на копирование
Предупреждение("Запрещено копировать Договора!");
Закрыть();
КонецЕсли;
КонецЕсли;


Подробнее:
Есть расширение формы документа ПараметрОбъектКопирования. В него при копировании помещается ссылка на документ оригинал.
Также есть расширение ПараметрОснование, в нем ссылка на основание.

Вот пример:
Код 1C v 8.х
 Процедура ПриОткрытии()

Если ЭтоНовый() Тогда

Если ПараметрОбъектКопирования = НЕОПРЕДЕЛЕНО Тогда
// заполняем реквизиты значениями по умолчанию
...

Иначе
...
КонецЕсли;
...

КонецЕсли;
...

КонецПроцедуры


Еще при копировании возникает событие ПриКопировании (OnCopy)
Синтаксис:
ПриКопировании(<ОбъектКопирования>)
Параметры:
<ОбъектКопирования>
Тип: СправочникОбъект.
Исходный элемент, который является источником копирования.
Описание:
Возникает при создании элемента справочника копированием.
Разместил:   Версии: | 8.x | 8.2 УП |  Дата:   Прочитано: 9669
 0 
Распечатать
Возможно, вас также заинтересует
17 правил для составления оптимального ЗАПРОСа к данным базы 1С 4
Для формирования и выполнения запросов к таблицам базы данных в платформе 1С используется специальный объект языка программирования Запрос . Создается этот объект вызовом конструкции Новый Запрос . Запрос удобно...
1Cv8.1CD - Файл данных достиг максимального размера! 4
1С выдает предупреждение " Файл данных достиг максимального размера" . Подскажите из - за чего это и как можно решить ? Превышен размер файла, обычно это сообщение возникает, когда размер файла 1Cv8.1CD приближается к 10...
COM-соединение не обнаружило свободной лицензии / ключ защиты 0
Иногда при подключении к 1С возникает ошибка: COM-соединение не обнаружило свободной лицензии! COM-соединение не обнаружило ключ защиты программы! https://helpf.pro/uploads/img/_1-UsuyAg6E2P.jpg В таких случаях, иногда, может помочь...
Microsoft SQL Server Native Client Добавление значения в столбец "datetime" привело к переполнению 0
При формировании отчета на СКД получили ошибку: Microsoft SQL Server Native Client 11.0: Добавление значения в столбец "datetime" привело к переполнению Подробнее текст такой: ... по причине: Ошибка компоновки данных по причине: Ошибка...
Автоматизация обмена данных используя обработку "Универсальный обмен данными в формате XML" 4
Автоматизация обмена между базами используя обработку " Универсальный обмен данными в формате XML" В основу данной публикации положены найденные мною материалы по cозданию обмена между двумя базами с использованием ...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.