helpf.pro
Регистрация
 +8 
Распечатать

1С 8.x : Удаление строк Таблицы Значений

Код 1C v 8.х
    
// 1. Удаление строк согласно условию
НулевыеСтроки = ТаблицаПослеПодмен.НайтиСтроки(Новый Структура("Сумма",0));
Для каждого СтрокаТаблицы Из НулевыеСтроки Цикл
ТаблицаПослеПодмен.Удалить(СтрокаТаблицы)
КонецЦикла;

// Нужно оставить строки только соответствующие условию,а остальные удалить то:
ПараметрыОтбора = Новый Структура("Цена",15000);
ТЗНов = ТЗ.Скопировать(ПараметрыОтбора);
// в результате в ТЗнов будут только строки из ТЗ, в которых значение поля Цена = 15000

// 2. Удаление определенной строки, например УдаляемаяСтрока = 5;
ТаблицаЗначений.Удалить(УдаляемаяСтрока);

// 3. Удаление первой строки
ТаблицаЗначений.Удалить(0);

// 4. Удаление определенной колонки, например УдаляемаяКолонка = 3;
ТаблицаЗначений.Колонки.Удалить(УдаляемаяКолонка);

// 5. Удалить первую колонку
ТаблицаЗначений.Колонки.Удалить(0);

// 6. Удаление строк перебором, проверяя условие
СтаршийИндексКолонок = ТаблицаЗначений.Колонки.Количество() - 1;
Индекс = ТаблицаЗначений.Количество() - 1;
Пока Индекс > = 0 Цикл
Для Сч = 0 По СтаршийИндексКолонок Цикл
Если ТипЗнч(ТаблицаЗначений[Индекс][Сч]) = Тип("Число") Тогда
ТаблицаЗначений.Удалить(Индекс);
Прервать;
КонецЕсли;
КонецЦикла;
Индекс = Индекс - 1;
КонецЦикла;
Разместил:   Версии: | 8.x |  Дата:   Прочитано: 36965
 +8 
Распечатать
Возможно, вас также заинтересует
1C и Google Maps 12
была поставлена задача отображения на географической карте медицинских учреждений. После обзора предлагаемых решений был выбран сервис google. Но так же подобного рода подход будет работать и с картами сервиса yandex. Во...
1Cv8.1CD - Файл данных достиг максимального размера! 3
1С выдает предупреждение " Файл данных достиг максимального размера" . Подскажите из - за чего это и как можно решить ? Превышен размер файла, обычно это сообщение возникает, когда размер файла 1Cv8.1CD приближается к 10...
COM-подключение к базе 7.7 из 8.2 1С 4
Если код выполняется на стороне клиента, то необходимо наличие базы 7.7 на локальной машине. Пример (На форме объекта присутствует реквизит Таблица(ТаблицаЗначений)): НаКлиенте Процедура Загрузки() ПутьКБазе="...
Excel файл как Внешний источник данных 4
Подключимся и загрузим из файла Excel данные в таблицу значений 1С. Сделать теперь это очень просто. 1. В конфигурации добавляет новый объект метаданных типа " Внешние источники данных" и назовем его просто " Excel" . ...
Google maps : вывод точек на карту и режим панорамы 2
В отличие от яндекс карт в GMaps можно использовать панорамы - за что им большой плюс! Надеюсь в яндексе прочитают этот пост и тоже когда-нибудь это сделают! Для клиента нужно было сделать вывод объектов на карту С...
Посмотреть все результаты поиска похожих
Комментарии
iof2000
15.08.2014 13:25Комментарий: 1
iof2000

Вот еще удобный способ удалять строки через ПостоительЗапроса

Код 1C v 8.х
 ИсточникДанных = Новый ОписаниеИсточникаДанных(ТЗ);
    Новыйзапрос = новый ПостроительОтчета;
    НовыйЗапрос.ИсточникДанных= ИсточникДанных;
    
    сзОтбор = Новыйзапрос.Отбор;             
    сзОтбор.Добавить("Колонка1");
    сзОтбор["Колонка1"].Использование = Истина;
    сзОтбор["Колонка1"].ВидСравнения = ВидСравнения.НеСодержит;
    сзОтбор["Колонка1"].Значение = "Итого";    
    Новыйзапрос.Выполнить();
    ТЗ = Новыйзапрос.Результат.Выгрузить();   
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.