helpf.pro
Регистрация
 0 
Распечатать

1С 8.x : Прочитать, просмотреть, выбрать записи регистра расчета

Код 1C v 8.х
 
// Просуммируем записи удержаний неявок по физлицу
НаборЗаписей = РегистрыРасчета.УдержанияРаботниковОрганизаций.СоздатьНаборЗаписей();
НаборЗаписей.Отбор.Регистратор.Значение = ВыбДокНачисл;
НаборЗаписей.Отбор.физлицо.Установить(Физлицо);
НаборЗаписей.Прочитать();
Для Каждого Запись Из НаборЗаписей Цикл
Если Запись.ВидРасчета=ПланыВидовРасчета.УдержанияОрганизаций.Неявка тогда
СумУдерж=СумУдерж+Запись.Результат;
КонецЕсли;
КонецЦикла;
Разместил:   Версии: | 8.x |  Дата:   Прочитано: 6773
 0 
Распечатать
Возможно, вас также заинтересует
Автоматическая установка ширины колонки табличного документа. 0
Процедура, которая " примерно" делает автоширину колонок (навроде, как если бы выделить все колонки и дважды щелкнуть мышкой по границе заголовка колонки). Привожу текст, работает неахти, но лучше чем ничего: Процедура...
Блокировка записей, невозможно изменить или удалить из регистра. Конфликт блокировок MS SQL + 1C 1
При попытке удалить запись из регистра сведений - получаю ошибку: она заблокирована, ошибка блокировок и т.д. Отключил всех пользователей, перезапустил сервер, пробую удалить - опять ошибка блокировки :( Путем тестов...
В ЗУП не исчисляются суммы районного коэффициента и северной надбавки? 1
В Зарплата и управление персоналом 8 почему при расчете среднего заработка для начисления очередного отпуска не исчисляются суммы районного коэффициента и северной надбавки? При исчислении среднего заработка во...
Ввести дату, ввод даты 1
ДатаНапоминания = РабочаяДата; Подсказка = "Введите дату и время"; ЧастьДаты = ЧастиДаты.ДатаВремя; Если ВвестиДату(ДатаНапоминания, Подсказка, ЧастьДаты) Тогда // обработка даты напоминания КонецЕсли Если...
Ввод данных по командировкам в программе ЗУП 0
Ввод сведений о командировках в программе 1С: Зарплата и управление персоналом 8 (ред.30) осуществляется в Разделе Кадры - Все кадровые документы - Создать - Командировка Откроется документ: Ввод сведений о...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.