helpf.pro
Регистрация
 0 
Распечатать

1С 8.x : Обработчик события для COM объекта

Добрый день.

Есть задача:
в элемент управления "Поле HTML документа" загружается некая web форма, на которой есть некий InputElement. Необходимо реализовать обработчик события onchange этого элемента.
Пытаюсь сделать так:
Код 1C v 8.х
 Процедура outMsgChange()
//какой-то код

КонецПроцедуры

Процедура FWДокументСформирован(Элемент)
FWDoc = ЭтаФорма.ЭлементыФормы.FW.Документ;
Если FWDoc.URLUnencoded= "file:///E:/index.html" Тогда

inMsg = FWDoc.all.inMessage;
outMsg = FWDoc.all.outMessage;
outMsg.onchange = outMsgChange;
КонецЕсли;
КонецПроцедуры


При проверке модуля возникает ошибка:
Переменная не определена (outMsgChange)
Толстый клиент (обычное приложение)

Есть какие-то варианты назначить для web контрола в качестве обработчика процедуру модуля?
Что-то аналогичное коду на C#:

this.FormClosed += new FormClosedEventHandler(Form1_FormClosed);

Спасибо.
Разместил:   Версии: | 8.x |  Дата:   Прочитано: 5311
 0 
Распечатать
Возможно, вас также заинтересует
Google maps : вывод точек на карту и режим панорамы 2
В отличие от яндекс карт в GMaps можно использовать панорамы - за что им большой плюс! Надеюсь в яндексе прочитают этот пост и тоже когда-нибудь это сделают! Для клиента нужно было сделать вывод объектов на карту С...
Ввод документа на основании - Программно 5
НовДок = Документы.ПеречислениеНДФЛвБюджет.СоздатьДокумент(); //Заполнить - вызывает ОбработкаЗаполнения(Основание) в документе ПеречислениеНДФЛвБюджет ...
Выгрузка / Загрузка данных посредством XML файлов? 0
В основе работы с XML-файлами лежит технология доступа SAX, которая осуществляет считывание по одному тегу. Для этого существует два типа данных – ЗаписьXML и ЧтениеXML . Запись данных справочника в XML-файл: Запись = Новый...
Горячие клавиши 1С 0
Конфигуратор 1С Конфигурация 1 Alt + К + Enter Открыть конфигурацию 2 Alt + К + Т Поиск во всех текстах 3 Alt + К + О Объединение конфигураций 4 Alt + K + З Загрузить измененную конфигурацию 5 Alt + К + Е Конвертирование...
Горячие клавиши 1С Разработчику [ Конфигуратор ] 20
Основные команды: Кодирование: Ctrl+Пробел - вызов подсказки Ctrl+Q - вызов шаблона Ctrl+F1 - поиск в синтакс-помощнике Ctrl + L - удалить текущую строку Alt+Shift+F - отформатировать код Исследование: F12 - ставим курсор на...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.