helpf.pro
Регистрация
 0 
Распечатать

1С 8.x : Формирование записей перерасчета

Код 1C v 8.х
 //Формирование записей перерасчета

Процедура СформироватьЗаписиПерерасчета()

// Запрос по записям регистра расчета. Запрос = Новый Запрос("
|ВЫБРАТЬ РАЗЛИЧНЫЕ
| СдельнаяВыработка.ФизЛицо,
| СдельнаяВыработка.Организация,
| ОсновныеНачисленияРегл.Регистратор,
| ОсновныеНачисленияРегл.ВидРасчета
|ИЗ
| РегистрНакопления.СдельнаяВыработка КАК СдельнаяВыработка
| ЛЕВОЕ СОЕДИНЕНИЕ
| РегистрРасчета.ОсновныеНачисленияРегл КАК ОсновныеНачисленияРегл
| ПО СдельнаяВыработка.ФизЛицо = ОсновныеНачисленияРегл.ФизЛицо
| И СдельнаяВыработка.Организация = ОсновныеНачисленияРегл.Организация
| И (СдельнаяВыработка.Период МЕЖДУ
| ОсновныеНачисленияРегл.ПериодДействияНачало
| И ОсновныеНачисленияРегл.ПериодДействияКонец)
|ГДЕ
| ОсновныеНачисленияРегл.ВидРасчета = &ВидРасчета
| И СдельнаяВыработка.Регистратор = &Регистратор
|ИТОГИ ПО
| Регистратор");

Запрос.УстановитьПараметр("ВидРасчета", ПланыВидовРасчета.ОсновныеНачисления.Сдельный);
Запрос.УстановитьПараметр("Регистратор", Ссылка);

ВыборкаДокументов = Запрос.Выполнить().
Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);

// Получение объекта ПерерасчетМенеджер.
Перерасчет = РегистрыРасчета.ОсновныеНачисленияРегл.
Перерасчеты.ПерерасчетОсновныхНачислений;

Пока ВыборкаДокументов.Следующий() Цикл

// Создание набора записей.
НаборЗаписей = Перерасчет.СоздатьНаборЗаписей(); НаборЗаписей.Отбор.ОбъектПерерасчета.Значение = ВыборкаДокументов.Регистратор;

Выборка = ВыборкаДокументов.Выбрать();
// Создание записей перерасчета. Пока Выборка.Следующий() Цикл
Запись = НаборЗаписей.Добавить(); Запись.ВидРасчета = Выборка.ВидРасчета; Запись.Организация = Выборка.Организация; Запись.ФизЛицо = Выборка.ФизЛицо;
КонецЦикла;

// Запись в таблицу без замещения. НаборЗаписей.Записать(Ложь);

КонецЦикла;

КонецПроцедуры
Разместил:   Версии: | 8.x | 8.2 УП |  Дата:   Прочитано: 8431
 0 
Распечатать
Возможно, вас также заинтересует
Автоматизация обмена данных используя обработку "Универсальный обмен данными в формате XML" 10
Автоматизация обмена между базами используя обработку " Универсальный обмен данными в формате XML" В основу данной публикации положены найденные мною материалы по cозданию обмена между двумя базами с использованием обработки " Универсальный обме
Автоматическая выгрузка загрузка данных используя регламентное задание 8
Для обмена данными между программами необходимо сделать следующее: 1. При помощи Конвертации Данных создать правила выгрузки данных 2. Нужно чтобы в конфигурации была обработка УниверсальныйОбменДаннымиXML , желательно последней версии! (При помо
Блокировка записей, невозможно изменить или удалить из регистра. Конфликт блокировок MS SQL + 1C 3
При попытке удалить запись из регистра сведений - получаю ошибку: она заблокирована, ошибка блокировок и т.д. Отключил всех пользователей, перезапустил сервер, пробую удалить - опять ошибка блокировки :( Путем тестов было вяснено, что проблема
Восстановление партионного учета в УТ 1
Проблема следующая: при выполнении стандартной обработки " проведение по партиям" , непонятно почему, но граница актуальности партионного учета не сдвигается, хотя при перепроведении документов никаких ошибок не возникает. Оказывается: дата гр
Временные таблицы 0
Не помню уже с какого релиза в запросах стало можно использовать временные таблицы. Для этого используется объект «Менеджер временных таблиц». Фактически менеджер временных таблиц описывает пространство имен временных таблиц и отвечает за их создание
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.