helpf.pro
Регистрация
 +11 
Распечатать

1С 8.x : Как программно прочитать Журнал Регистрации?

Код 1C v 8.х
  ИмяФайла=ПолучитьИмяВременногоФайла("XML");
Результат.Очистить();
Фильтр=Новый Структура;
Фильтр.Вставить("ДатаНачала", НачалоПериода);
Фильтр.Вставить("ДатаОкончания", ОкончаниеПериода);
Фильтр.Вставить("Событие", "_$Data$_.Post");
Состояние("Выгрузка журнала...");
ВыгрузитьЖурналРегистрации(ИмяФайла, Фильтр, "Дата, Метаданные, Данные, ПредставлениеДанных, ИмяПользователя");
Состояние("Обработка журнала...");
ЧтениеXML=Новый ЧтениеXML;
ЧтениеXML.ОткрытьФайл(ИмяФайла);
ПостроительDOM=Новый ПостроительDOM;
ДокументDOM=ПостроительDOM.Прочитать(ЧтениеXML);
Event=ДокументDOM.ПолучитьЭлементыПоИмени("v8e:Event");
Для й=0 По Event.Количество()-1 Цикл
ДочерниеУзлы=Event[й].ДочерниеУзлы;
Для Каждого Узел Из ДочерниеУзлы Цикл
Если Узел.ИмяУзла="v8e:Date" Тогда
ДатаСобытия=СтрЗаменить(Узел.ТекстовоеСодержимое, "T", "");
ДатаСобытия=СтрЗаменить(ДатаСобытия, ":", "");
ДатаСобытия=Дата(СтрЗаменить(ДатаСобытия, "-", ""));
ИначеЕсли Узел.ИмяУзла="v8e:MetadataName" Тогда
МетаданныеДокумента=СтрЗаменить(Узел.ТекстовоеСодержимое, "Document.", "");
ИначеЕсли Узел.ИмяУзла="v8e:Data" Тогда
УИД=Узел.ТекстовоеСодержимое;
ИначеЕсли Узел.ИмяУзла="v8e:DataPresentation" Тогда
ПредставлениеДанных=Узел.ТекстовоеСодержимое;
ИначеЕсли Узел.ИмяУзла="v8e:UserName" Тогда
Пользователь=Узел.ТекстовоеСодержимое;
КонецЕсли;
КонецЦикла;
Ссылка=Документы[МетаданныеДокумента].ПолучитьСсылку(Новый УникальныйИдентификатор(УИД));
ДатаОбъекта=Ссылка.Дата;

НоваяСтрока=Результат.Добавить();
НоваяСтрока.ДатаСобытия=ДатаСобытия;
НоваяСтрока.ДатаОбъекта=ДатаОбъекта;
НоваяСтрока.ПредставлениеДанных=ПредставлениеДанных;
НоваяСтрока.Пользователь=Пользователь;
НоваяСтрока.РазностьДат=Окр((ДатаСобытия-ДатаОбъекта)/86400);
НоваяСтрока.Ссылка=Ссылка;
КонецЦикла;
Разместил:   Версии: | 8.x | 8.2 УП |  Дата:   Прочитано: 35018
 +11 
Распечатать
Возможно, вас также заинтересует
Ввод документа на основании - Программно 11
НовДок = Документы.ПеречислениеНДФЛвБюджет.СоздатьДокумент(); //Заполнить - вызывает ОбработкаЗаполнения(Основание) в документе ПеречислениеНДФЛвБюджет НовДок.Заполнить(ЭлементыФормы.ДокументСписок.ТекущаяСтрока); НовДок.ПолучитьФорму().Открыть()
Внешние обработки, печатные формы, обработки по заполнению табличных частей 3
Справочник «Внешние обработки, печатные формы, обработки по заполнению табличных частей» содержит список произвольных обработок, произвольных отчетов, дополнительных печатных форм, обработок для заполнения ТЧ объектов, обработок, подключаемых к отч
Восстановление узла распределенной информационной базы из резервной копии 0
В случае возникновения ситуации, при которой необходимо восстановить резервную копию информационной базы, работающую в рамках распределенной информационной базы, можно воспользоваться следующими рекомендациями. Процедура восстановления информационно
Выбрать движения, получить выборку записей регистра накопления 1
Пример 1 : //Взаиморасчеты за период, хотя, это лучше выбирать запросом , он в примере 3 Отбор = Новый Структура("Организация", Организация); НаборЗаписей = РегистрыНакопления.ВзаиморасчетыСРаботникамиОрганизаций.Выбрать(ПериодРегистрации, КонецМе
Выгрузка из 1С на SFTP 4
Думаю, что все знают, как работает 1с с FTP сервером, но вот как работать с sFTP или FTPs сервером? Первое что Вам нужно сделать - это установить бесплатную программу WinSCP, скачать ее Вы сможете здесь, также там есть вся необходимая литература п
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.