helpf.pro
Регистрация
 0 
Распечатать

1С 8.x : Табличное поле ~ Как установить значения для новой строки

При добавлении новой строки нужно заполнить дату добавления и имя пользователя!

Добавлена строка может быть или кнопкой INS (добавление) или кнопкой F9 (дублирование).

При добавлении последовательность событий такая:

* ПередНачаломДобавления - строка еще не доступна

При дублировании последовательность событий такая:

* ПередНачаломДобавления - строка еще не доступна

* ПриАктивизацииЯчейки - строка уже доступна, но строка пустая.

* Повторная ПриАктивизацииЯчейки - строка уже заполнена. 

Как быть?

Для решения данной задачи необходимо использовать ПриНачалеРедактирования:

Код 1C v 8.х
 Процедура ОтчетПриНачалеРедактирования(Элемент, НоваяСтрока, Копирование)
Если НоваяСтрока Тогда
Элемент.ТекущиеДанные.Дата = ТекущаяДата();
Элемент.ТекущиеДанные.Менеджер = ПараметрыСеанса.ТекущийПользователь;
КонецЕсли;
КонецПроцедуры

В реалии это выглядит так, нажали добавить и получили:

Разместил:   Версии: | 8.x |  Дата:   Прочитано: 7178
 0 
Распечатать
Возможно, вас также заинтересует
17 правил для составления оптимального ЗАПРОСа к данным базы 1С 12
Для формирования и выполнения запросов к таблицам базы данных в платформе 1С используется специальный объект языка программирования Запрос . Создается этот объект вызовом конструкции Новый Запрос . Запрос удобно...
1C и Google Maps 12
была поставлена задача отображения на географической карте медицинских учреждений. После обзора предлагаемых решений был выбран сервис google. Но так же подобного рода подход будет работать и с картами сервиса yandex. Во...
COM-подключение к базе 7.7 из 8.2 1С 5
Если код выполняется на стороне клиента, то необходимо наличие базы 7.7 на локальной машине. Пример (На форме объекта присутствует реквизит Таблица(ТаблицаЗначений)): НаКлиенте Процедура Загрузки() ПутьКБазе="...
Cклонения по падежам 4
НаКлиенте Процедура Команда1(Команда) ФИО = " Иванов Иван Иванович" ; Падеж = 2; Пол = 1; Результат = СклонениеФИО(ФИО, Падеж, пол); Сообщить(Результат); КонецПроцедуры НаСервере Функция СклонениеФИО(ФИО, Падеж, пол) ...
Excel файл как Внешний источник данных 6
Подключимся и загрузим из файла Excel данные в таблицу значений 1С. Сделать теперь это очень просто. 1. В конфигурации добавляет новый объект метаданных типа " Внешние источники данных" и назовем его просто " Excel" . ...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.