helpf.pro
Регистрация
 +1 
Распечатать

1С 8.x : Как в универсальном отчете отключить вывод итогов по некоторым полям?

В универсальном отчете понадобилось отключить вывод итого по некоторым полям, но в универсальном отчете, созданном через построитель, к сожалению это невозможно )

Многие скажут - что давно пора использовать СКД и там все есть! - согласен на все 100% ) но есть клиенты у которых стоит программа УТ с 2012 года, их все устраивает и ничего не хотят менять, кроме отчетов. Вот один мой знакомы попросил отключить итоги в универсальном отчете - сделал это добавив следующий код в процедуру формирования отчета:

Код 1C v 8.х
 // Процедура формирования отчета
//
Процедура СформироватьОтчет(ТабличныйДокумент) Экспорт

Если НЕ ЗначениеЗаполнено(УниверсальныйОтчет.ДатаКон) Тогда 
УниверсальныйОтчет.ДатаКон = ТекущаяДата();
КонецЕсли;

// Перед формирование отчета можно установить необходимые параметры универсального отчета.
УниверсальныйОтчет.ПостроительОтчета.Параметры.Вставить("ДатаОтчета", КонецДня(УниверсальныйОтчет.ДатаКон));
УниверсальныйОтчет.ПостроительОтчета.Параметры.Вставить("ДатаНеделяНазад", УниверсальныйОтчет.ДатаКон-(86400*7));


//УстановитьИнтервалыЗапроса();

УниверсальныйОтчет.СформироватьОтчет(ТабличныйДокумент);

// ДОБАВЛЕННЫЙ КОД - чистит итоги в нужных ячейках
Для а = 11 по ТабличныйДокумент.ВысотаТаблицы Цикл
//Ячейка = ТабличныйДокумент.Область(а,1,а,1).Текст; 
текстЯчейка = ТабличныйДокумент.Область("R"+а+"C2").Текст; 
Если Строка(ТабличныйДокумент.Область("R"+а+"C2").ЦветФона)="стиль: Фон кнопки" Тогда
ТабличныйДокумент.Область("R"+а+"C7").Текст="";
ТабличныйДокумент.Область("R"+а+"C11").Текст="";
ТабличныйДокумент.Область("R"+а+"C8").Текст="";
ТабличныйДокумент.Область("R"+а+"C9").Текст="";
ТабличныйДокумент.Область("R"+а+"C10").Текст="";
КонецЕсли;
КонецЦикла;
КонецПроцедуры // СформироватьОтчет()

Для наглядности покажу на примере:

в выделенных полях добавленным кодом были стерты итоги

Разместил:   Версии: | 8.x |  Дата:   Прочитано: 2961
 +1 
Распечатать
Возможно, вас также заинтересует
Автоматическая установка ширины колонки табличного документа. 0
Процедура, которая " примерно" делает автоширину колонок (навроде, как если бы выделить все колонки и дважды щелкнуть мышкой по границе заголовка колонки). Привожу текст, работает неахти, но лучше чем ничего: Процедура...
В отчет не попадают данные за последний день… Как исправить? 0
Пользователь выбрал период формирования отчета с 1июля по 31. Почему при формировании отчета в него не попадают данные за 31 число? На самом деле, это одна из самых распространенных ошибок при разработке отчетов. В 1С 8.х...
Внешние обработки, печатные формы, обработки по заполнению табличных частей 2
Справочник «Внешние обработки, печатные формы, обработки по заполнению табличных частей» содержит список произвольных обработок, произвольных отчетов, дополнительных печатных форм, обработок для заполнения ТЧ...
Временные таблицы в отчетах СКД 0
Нужно в отчете СКД Связать Данные из Регистра Накопления ВзаиморасчетыСРаботниками и Табличной Части Документа ЗарплатаКВыплате по Ссылке на Документ и ФизЛицу! И вывести полученные данные за указанный Период(с...
Временные таблицы, что из себя представляют и как с ними работать? 5
Временные таблицы - хранятся на сервере и позволяют писать более простые запросы. Временные таблицы хранятся в объекте типа МенеджерВременныхТаблиц . Когда этот объект уничтожается, уничтожаются и временные...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.