helpf.pro
Регистрация
 +2 
Распечатать

1С 8.x : Как удалить строку или очистить дерево значений

Помните, что при при удалении/очистке строки, все подчиненные строки удаляются.

Очистить дерево значений: Дерево.Строки.Очистить();

Код 1C v 8.2 УП
 &НаСервере
Процедура ОчиститьНаСервере()
   тДерево = РеквизитФормыВЗначение("Дерево");
 
   тДерево.Строки.Очистить();
 
   ЗначениеВРеквизитФормы(тДерево, "Дерево");
КонецПроцедуры

Точно также можно очистить от подчиненных элементов другую другую строку.

Удалить строку дерева значений не сложнее & нужно только знать ее индекс:

Код 1C v 8.2 УП
 &НаКлиенте
Процедура Удалить(Команда)
   УдалитьНаСервере();
КонецПроцедуры
 
&НаСервере
Процедура УдалитьНаСервере()
   тДерево = РеквизитФормыВЗначение("Дерево");
 
   тДерево.Строки.Удалить(0);
 
   ЗначениеВРеквизитФормы(тДерево, "Дерево");
КонецПроцедуры
Разместил:   Версии: | 8.x | 8.2 УП | 8.3 |  Дата:   Прочитано: 47384
 +2 
Распечатать
Возможно, вас также заинтересует
17 правил для составления оптимального ЗАПРОСа к данным базы 1С 51
Для формирования и выполнения запросов к таблицам базы данных в платформе 1С используется специальный объект языка программирования Запрос . Создается этот объект вызовом конструкции Новый Запрос . Запрос удобно использовать, когда требуется получ
COM-подключение к базе 7.7 из 8.2 1С 7
Если код выполняется на стороне клиента, то необходимо наличие базы 7.7 на локальной машине. Пример (На форме объекта присутствует реквизит Таблица(ТаблицаЗначений)): НаКлиенте Процедура Загрузки() ПутьКБазе=" D:ВашаБаза1с77" ; Пользователь=
Excel файл как Внешний источник данных 16
Подключимся и загрузим из файла Excel данные в таблицу значений 1С. Сделать теперь это очень просто. 1. В конфигурации добавляет новый объект метаданных типа " Внешние источники данных" и назовем его просто " Excel" . https://helpf.pro/uploads/img
Google maps : вывод точек на карту и режим панорамы 9
В отличие от яндекс карт в GMaps можно использовать панорамы - за что им большой плюс! Надеюсь в яндексе прочитают этот пост и тоже когда-нибудь это сделают! Для клиента нужно было сделать вывод объектов на карту С возможностью просмотра панора
Автоматизация обмена данных используя обработку "Универсальный обмен данными в формате XML" 10
Автоматизация обмена между базами используя обработку " Универсальный обмен данными в формате XML" В основу данной публикации положены найденные мною материалы по cозданию обмена между двумя базами с использованием обработки " Универсальный обме
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.