helpf.pro
Регистрация
 +1 
Распечатать

1С 8.x : Функция получает номер последнего указанного Символа в Исходной строке

Код 1C v 8.х
 // Например необходимо:
// в строке "C:\Documents and Settings\E.S.Migachev\Рабочий стол\1С" получить номер последнего символа "\"
//Ном= ПолучитьНомерПоследнегоСимвола( "C:\Documents and Settings\E.S.Migachev\Рабочий стол\1С", "\")
//в результате Ном=53
Функция ПолучитьНомерПоследнегоСимвола(Знач ИсходнаяСтрока, Знач СимволПоиска)
ПозицияСимвола = СтрДлина(ИсходнаяСтрока);
Пока ПозицияСимвола >= 1 Цикл
Если Сред(ИсходнаяСтрока, ПозицияСимвола, 1) = СимволПоиска Тогда
Возврат ПозицияСимвола;
КонецЕсли;
ПозицияСимвола = ПозицияСимвола - 1;
КонецЦикла;
Возврат 0;
КонецФункции
Разместил:   Версии: | 8.x |  Дата:   Прочитано: 5809
 +1 
Распечатать
Возможно, вас также заинтересует
QR код в 1С 10
Столкнулся с интересной задачей реализации генерации QR-кода в 1С 8.2 ( QR-код — матричный код (двухмерный штрихкод) ) Для генерации было использовано api от google (http://chart.apis.google.com/chart). Вот сайт , который работает с ним. После...
Автоматическая установка ширины колонки табличного документа. 0
Процедура, которая " примерно" делает автоширину колонок (навроде, как если бы выделить все колонки и дважды щелкнуть мышкой по границе заголовка колонки). Привожу текст, работает неахти, но лучше чем ничего: Процедура...
Возвратить каталог файла - часть пути без имени файла 0
// ПутьКФайлу – Строка – путь к файлу. // // Возвращаемое значение: // Строка – каталог файла // Функция ПолучитьКаталогФайла(Знач ПутьКФайлу) Экспорт ПозицияСимвола = СтрДлина(ПутьКФайлу); Пока ПозицияСимвола = 1...
Выгрузка / Загрузка данных посредством текстовых (TXT) файлов 2
Для работы с текстовыми документами существуют три типа данных – ТекстовыйДокумент, ЗаписьТекста и ЧтениеТекста . Разница двух подходов состоит в способе загрузки документа: ТекстовыйДокумент загружает файл...
Выгрузка метаданных конфигурации в Microsoft Word и Excel 0
Перем ОбъектыКонфы; Перем СтруктКонфы; Процедура ВыгрузитьВWord() Попытка Word = Новый COMОбъект(" Word.Application" ); Исключение Сообщить(" Не удалось открыть Word" ); Возврат; КонецПопытки; Word.Documents.Add(); Документ = Word.Activ
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.