helpf.pro
Регистрация
 +1 
Распечатать

1С 8.x : Функция копирования файла с выводом сообщений о результатах

Код 1C v 8.х
 //Возвращает Истина - скопирован, иначе Ложь 
Функция СкопироватьФайл(ИмяФайлаИсточник, ИмяФайлаНазначение, ВыдаватьСообщения = Ложь) Экспорт
Попытка
ПозицияСимвола = СтрДлина(ИмяФайлаНазначение);
Пока ПозицияСимвола >= 1 Цикл
Если Сред(ИмяФайлаНазначение, ПозицияСимвола, 1) = "\" Тогда
Возврат ПозицияСимвола;
КонецЕсли;
ПозицияСимвола = ПозицияСимвола - 1;
КонецЦикла;
КаталогФайла=Сред(ИмяФайлаНазначение, 1, ПозицияСимвола - 1);
СоздатьКаталог(КаталогФайла);
КопироватьФайл(ИмяФайлаИсточник, ИмяФайлаНазначение);
Исключение
Сообщение = "Ошибка при копировании: " + ОписаниеОшибки() +
" (источник: " + ИмяФайлаИсточник + "; приемник: " + ИмяФайлаНазначение + ")";
Если ВыдаватьСообщения Тогда
Сообщить(Сообщение);
КонецЕсли;
Предупреждение(Сообщение);
Возврат Ложь;
КонецПопытки;
Возврат Истина;
КонецФункции
Разместил:   Версии: | 8.x |  Дата:   Прочитано: 6691
 +1 
Распечатать
Возможно, вас также заинтересует
ZIP-архив Разделить и Объединить Файл 0
При работе с большими объемами данных могут возникнуть проблемы при пересылке архивных файлов. Типичной такой ситуацией является ограничение некоторых почтовых серверов на размер сообщения - если письмо превышает...
Автоматизация обмена данных используя обработку "Универсальный обмен данными в формате XML" 3
Автоматизация обмена между базами используя обработку " Универсальный обмен данными в формате XML" В основу данной публикации положены найденные мною материалы по cозданию обмена между двумя базами с использованием ...
Восстановление узла распределенной информационной базы из резервной копии 0
В случае возникновения ситуации, при которой необходимо восстановить резервную копию информационной базы, работающую в рамках распределенной информационной базы, можно воспользоваться следующими рекомендациями. ...
Горячие клавиши 1С 0
Конфигуратор 1С Конфигурация 1 Alt + К + Enter Открыть конфигурацию 2 Alt + К + Т Поиск во всех текстах 3 Alt + К + О Объединение конфигураций 4 Alt + K + З Загрузить измененную конфигурацию 5 Alt + К + Е Конвертирование...
Горячие клавиши 1С Пользователю [ Предприятие] 0
Основные команды: Интерфейс: F6 - переключение между формами рабочего стола F10 - переход в главное меню окна Alt+1 - переход на панель Разделов Alt+2 - переход на панель Навигации Alt+3 - переход на панель Действий Alt+9 -...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.