helpf.pro
Регистрация
 0 
Распечатать

1С 8.x : Помечен ли элемент справочника на удаление

Код 1C v 8.х
  //можно проверить, помечен ли элемент на удаление
//есть свойство ПометкаУдаления, оно имеет тип Булево - Истина или Ложь
Пометка = СпрСотр.ПометкаУдаления; //обратите внимание: это свойство
Если Пометка = Истина Тогда
.....//элемент помечен на удаление
КонецЕсли;

Код 1C v 7.x
 
//пом=1 если ставим пометку
//пом =0 если хотим снять пометку
спр=СоздатьОбъект("Справочник.Материалы");
спр.ВыбратьЭлементы();
Пока спр.ПолучитьЭлемент()=1 Цикл
Если пом=1 Тогда
спр.удалить(0);//если поставить 1, то будет непосредственное удаление
иначе
спр.СнятьПометкуУдаления();
КонецЕсли;
КонецЦикла;
Предупреждение("Обработка завершена");
Разместил:   Версии: | 7.x | 8.x |  Дата:   Прочитано: 13133
 0 
Распечатать
Возможно, вас также заинтересует
Cклонения по падежам 6
НаКлиенте Процедура Команда1(Команда) ФИО = " Иванов Иван Иванович" ; Падеж = 2; Пол = 1; Результат = СклонениеФИО(ФИО, Падеж, пол); Сообщить(Результат); КонецПроцедуры НаСервере Функция СклонениеФИО(ФИО, Падеж, пол) Результат = " " ;
Cообщение: "Не удалось удалить чеки ККМ!" 2
Пользователь с правами Администратор ККМ проводит Закрытие кассовой смены (Z). Выходит сообщение: " Не удалось удалить чеки ККМ!" ФР печатает Z -отчет, но Отчет о рознчничных продажах не формируется. Необходимо дать роли Администратор ККМ прав
Был ли изменен элемент справочника? 0
// Модифицированность() - Определяет, был ли изменен объект после считывания из базы данных. // НО Метод не позволяет определить, был ли изменен объект другими пользователями. Если Модифицированность() тогда Сообщить(" Этот элемент справочник
Ввод дополнительного ежегодного отпуска 2
Вид расчета, используемый для начисления оплаты дополнительного ежегодного отпуска , описывается в плане видов расчета Основные начисления организаций . Новый вид расчета удобнее создать копированием предопределенного вида расчета Оплата отпуска п
Внешние обработки, печатные формы, обработки по заполнению табличных частей 3
Справочник «Внешние обработки, печатные формы, обработки по заполнению табличных частей» содержит список произвольных обработок, произвольных отчетов, дополнительных печатных форм, обработок для заполнения ТЧ объектов, обработок, подключаемых к отч
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.