helpf.pro
Регистрация
 0 
Распечатать

1С 8.x : Запрос к базе данных SQL

Код 1C v 8.х
 Функция ПодключитьCOMОбъект(Путь) Экспорт 
Отказ = Ложь;

COMСоединение = Новый COMОбъект("ADODB.Connection");
COMСоединение.ConnectionString = ".....";
COMСоединение.ConnectionTimeOut = 1200;
COMСоединение.CursorLocation = 3;

Попытка
COMСоединение.Open(COMСоединение.ConnectionString);
Исключение
Отказ = Истина;
COMСоединение = "";
Предупреждение("Невозможно установить соединение - " + ОписаниеОшибки());
Возврат НЕ Отказ;
КонецПопытки;

Возврат НЕ Отказ;
КонецФункции

Процедура КнопкаВыплонитьНажатие(Кнопка)
Если НЕ ПодключитьCOMОбъект(ПутьКФайлуГДБ) Тогда
ЗакрытьФормуИндикатора();
Возврат;
КонецЕсли;


КомандаАДО = Новый COMОбъект("ADODB.Command");

ТекстЗапроса = "S_elect id from nomenclature where ext_1c_id = 1";

Рекордсет = Новый COMОбъект("ADODB.Recordset");
Попытка
Рекордсет = КомандаАДО.Execute();
Исключение
Предупреждение("Не получилось выполнить запрос!" + " - " + ОписаниеОшибки());
КонецПопытки;
Рекордсет.MoveFirst();
Пока Рекордсет.EOF() = 0 Цикл
ОбработкаПрерыванияПользователя();
айди = Рекордсет.Fields("id").Value;
Сообщить(айди);
КонецЦикла;
КонецПроцедуры

еще пример:
Код 1C v 8.х
 стрПодключения = "Driver={SQL Server};"
стрПодключения = стрПодключения + ИмяСервера + ";";
стрПодключения = стрПодключения +"Uid=" + ИмяПользователя + ";";
стрПодключения = стрПодключения + "Pwd=" + Пароль + ";";
стрПодключения = стрПодключения + "DataBase =" + ИмяБазы + ";";
стрПодключения = стрПодключения + "Pwd=" + Пароль + ";";

Connection = Новый COMОбъект("ADODB.Connection");
Connection.OpenServer = стрПодключения;

RS = Новый COMОбъект("ADODB.Recordset");

// Запрос к базе на языке SQL запросов.
RS.Open("S_elect * from TradeUnit", Connection);

Пока RS.EOF() = 0 Цикл

// Можно обращаться и обрабатывать значения полей выборки.
ИД = RS.Fields("ID").Value;
Код = RS.Fields("Code").Value;
// Обработка других полей
RS.MoveNext();
КонецЦикла;

RS.Close();
Connection.Close();
Разместил:   Версии: | 8.x |  Дата:   Прочитано: 17281
 0 
Распечатать
Возможно, вас также заинтересует
1C медленно работает по сети с базой на SQL Server 8
Данное обстоятельство может быть обусловлено многими причинами. Одна из них - неоптимальная настройка MS SQL . Перечислим неоптимальности в настройке: 1) Неправильно указанный сетевой протокол, используемый для...
1Cv8.1CD - Файл данных достиг максимального размера! 3
1С выдает предупреждение " Файл данных достиг максимального размера" . Подскажите из - за чего это и как можно решить ? Превышен размер файла, обычно это сообщение возникает, когда размер файла 1Cv8.1CD приближается к 10...
1С Предприятие что это? 6
Что такое 1С? 1С — это фирма , у которой одно из направлений деятельности — разработка программного обеспечения для автоматизации бизнес-процессов предприятий. « 1С:Предприятие » - конкретный продукт, который...
COM-подключение к базе 7.7 из 8.2 1С 4
Если код выполняется на стороне клиента, то необходимо наличие базы 7.7 на локальной машине. Пример (На форме объекта присутствует реквизит Таблица(ТаблицаЗначений)): НаКлиенте Процедура Загрузки() ПутьКБазе="...
Cклонения по падежам 4
НаКлиенте Процедура Команда1(Команда) ФИО = " Иванов Иван Иванович" ; Падеж = 2; Пол = 1; Результат = СклонениеФИО(ФИО, Падеж, пол); Сообщить(Результат); КонецПроцедуры НаСервере Функция СклонениеФИО(ФИО, Падеж, пол) ...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.