helpf.pro
Регистрация
 0 
Распечатать

1С 8.x : Функция Получает переменную заключенную в скобки [ ]

Код 1C v 8.х
 //Пример: СТР = "Тест [наш]ей функции" 
//НовСтр=ПолучитьПеременнуюИзСтроки(СТР)
//В итоге НовСтр="наш";

Функция ПолучитьПеременнуюИзСтроки(ПереданнаяСтрока) Экспорт
Переменная = "";
ПервыйСимвол = Найти(ПереданнаяСтрока,"[");
Если ПервыйСимвол > 0 Тогда
ВторойСимвол = Найти(ПереданнаяСтрока,"]");
Если (ВторойСимвол > 0) И (ВторойСимвол > ПервыйСимвол) Тогда
Переменная = (Сред(ПереданнаяСтрока,ПервыйСимвол+1,ВторойСимвол-ПервыйСимвол-1));
КонецЕсли;

КонецЕсли;
Возврат Переменная;
КонецФункции
Разместил:   Версии: | 8.x |  Дата:   Прочитано: 4942
 0 
Распечатать
Возможно, вас также заинтересует
Имитация (программное) нажатия Клавиш 0
В системе " 1С:Предприятие" часто возникает ситуация, когда нужно закрыть окно сообщений, появляющееся при вызове метода Сообщить. Стандартно это окно закрывается при нажатии комбинации клавиш Ctrl + Shift + Z , но можно...
Как сформировать новый договор, документ на основании файла, шаблона Microsoft Office Word? 0
Для заключения договоров с контрагентами разработан типовой договор (шаблон). При его оформлении (для реального контрагента) в определенные места документа вставляются данные о контрагенте. Подобные фрагменты...
Как сформировать новый документ на основании файла, шаблона Microsoft Office Word и OpenOffice? 1
Перем СсылкаНаДокумент; Процедура СформироватбФайл_MS_Word_И_OpenOffice(Кнопка) ДокументСсылка = СсылкаНаДокумент; ИмяФайла = ПолучитьИмяВременногоФайла(); // Теперь формируем файл из MS Wordа Попытка MSWord = новый COMОбъект("...
Набор функций для работы с разделителями в строке 0
// Функция разбивает строку разделителем. // // Параметры: // пСтрока - Строка - которую разбиваем; // *пРазделитель - Строка, " ." - символ-разделитель; // *ОбрезатьНепечатныеСимволы - Булево, *Ложь. // // Возвращаемое...
Обмен между базами через XML (создается ФабрикаXDTO) 1
В процедурах выгрузки/загрузки создается ФабрикаXDTO из схемы, которая хранится в макете как файл. Файл настроек схемы надо использовать один и тот же в обработках Загрузки/Выгрузки Из Фабрики создается объект, его...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.