helpf.pro
Регистрация
 0 
Распечатать

1С 8.x : Функция проверяет соответствие КПП Контрагента требованиям

Код причины постановки на учёт (КПП) представляет собой девятизначный цифровой код, который вместе с ИНН организации позволяет однозначно идентифицировать её обособленные подразделения (см. КПП в Википедии).

Структура КПП:

* 4 цифры – код подразделения ФНС России (справочник СОУН);
* 2 цифры – код причины постановки на учёт;
* 3 цифры – порядковый номер постановки на учёт;

В большинстве случаев КПП выглядит как: код подразделения ФНС + 01001 поскольку не так уж много организаций имеют обособленные подразделения.

К недостаткам КПП можно отнести невозможность проверки КПП по контрольной сумме. Максимум можно проверить “разумность” заполнения каждого из его элементов. В общем случае КПП не несёт больше информации чем несёт ИНН, и практически никогда не используется по отдельности в ИНН организации.

Код 1C v 8.х
 // Параметры:
// КПП - строка - проверяемый код причины постановки на учет
Функция КППСоответствуетТребованиям(Знач КПП) Экспорт

Если НЕ ТолькоЦифрыВСтроке(КПП) Тогда
Возврат Ложь;
КонецЕсли;

Если СтрДлина(СтрЗаменить(Строка(КПП), "0", "1")) <> 9 Тогда
Возврат Ложь;
КонецЕсли;

Возврат Истина;

КонецФункции
Разместил:   Версии: | 8.x |  Дата:   Прочитано: 9945
 0 
Распечатать
Возможно, вас также заинтересует
ДБФ, работа с Индекс, Ключ 0
ФайлНаДиске = Новый Файл(ИмяФайла); Если НЕ(ФайлНаДиске.Существует()) Тогда Предупреждение(" Файл с таким именем не существует " + ИмяФайла); Возврат; КонецЕсли; ДБФ = Новый xBase; ДБФ.Кодировка = КодировкаXBase.OEM; ДБФ.ОткрытьФайл(ИмяФайл
Добавление в список значений элементов справочника помеченных на удаление и управление ими 0
СписокЗначений = Новый СписокЗначений; Запрос = Новый Запрос; Запрос.Текст=" ВЫБРАТЬ | Подразделения.Ссылка, | Подразделения.Наименование, | Подразделения.ПометкаУдаления |ИЗ | Справочник.Подразделения КАК Подразделения |ГДЕ Подразделения.По
Использование RLS 3
Начиная с платформы 8.0 системы 1С Предприятие, существует возможность ограничивать права доступа пользователей на уровне записей. Для этого используется механизм RLS (Record Level Security). Такая «тонкая» настройка может быть полезна для ограничени
Как в 1С Бухгалтерии изменить должность сотрудника, после повышения? 0
Вопрос: Как в 1С Бухгалтерия 8 ПРОФ поменять должность «кладовщик» на «зав.складом», если было повышение? Ответ: Перевод сотрудника внутри организации на другое постоянное место работы регистрируется в программе "1С:Бухгалтерия 8" (редакция 2.0)
Как в ЗУПе выбрать всех сотрудников, когда-либо работавших в выбранном подразделении? 2
Как в ЗУПе выбрать всех сотрудников, когда-либо работавших в выбранном подразделении и изменить у них значение указанного реквизита. Запрос=Новый Запрос; Запрос.Текст=" |ВЫБРАТЬ РАЗЛИЧНЫЕ | РаботникиОрганизаций.Сотрудник, | РаботникиОрганизаций
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.