helpf.pro
Регистрация
 0 
Распечатать

Добавление в список значений элементов справочника помеченных на удаление и управление ими

Код 1C v 8.х
 СписокЗначений = Новый СписокЗначений;

Запрос = Новый Запрос;
Запрос.Текст="ВЫБРАТЬ
| Подразделения.Ссылка,
| Подразделения.Наименование,
| Подразделения.ПометкаУдаления
|ИЗ
| Справочник.Подразделения КАК Подразделения
|ГДЕ Подразделения.ПометкаУдаления = ИСТИНА";
Результат = Запрос.Выполнить().Выбрать();
Пока Результат.Следующий() Цикл
Если Результат.ПометкаУдаления Тогда
Пометка = Истина;
иначе
пометка = Ложь;
КонецЕсли;
СписокЗначений.Добавить(Результат.Ссылка, Результат.Наименование, Пометка,);
КонецЦикла;
//
СписокЗначений.ОтметитьЭлементы("Выберите элементы для удаления");

Для каждого ТекЭлемент Из СписокЗначений Цикл
Если НЕ ТекЭлемент.Пометка Тогда // если убрали пометку, то убираем и в справочнике
ТекЭлемент.Значение.ПолучитьОбъект().УстановитьПометкуУдаления(Ложь,); // Подчиненные помечать на удаление не будем
КонецЕсли;
КонецЦикла
Разместил:   Версии: | 8.x |  Дата:   Прочитано: 7924
 0 
Распечатать
Возможно, вас также заинтересует
1С Предприятие что это? 6
Что такое 1С? 1С — это фирма , у которой одно из направлений деятельности — разработка программного обеспечения для автоматизации бизнес-процессов предприятий. « 1С:Предприятие » - конкретный продукт, который...
Cклонения по падежам 4
НаКлиенте Процедура Команда1(Команда) ФИО = " Иванов Иван Иванович" ; Падеж = 2; Пол = 1; Результат = СклонениеФИО(ФИО, Падеж, пол); Сообщить(Результат); КонецПроцедуры НаСервере Функция СклонениеФИО(ФИО, Падеж, пол) ...
Cодержимое указанного ниже веб-сайта в этом приложении блокируется... Aboutsecurity_1cv8c.exe 0
Проблема: После обновления на 1С:Бухгалтерию предприятия 3-й версии, при нажатии на закладку командного интерфейса 1С:предприятие, выскакивает ошибка: Aboutsecurity_1cv8c.exe или Aboutsecurity_1cv8.exe «Содержимое указанного ниже...
Cообщение: "Не удалось удалить чеки ККМ!" 2
Пользователь с правами Администратор ККМ проводит Закрытие кассовой смены (Z). Выходит сообщение: " Не удалось удалить чеки ККМ!" ФР печатает Z -отчет, но Отчет о рознчничных продажах не формируется. Необходимо дать...
В ЗУП не исчисляются суммы районного коэффициента и северной надбавки? 1
В Зарплата и управление персоналом 8 почему при расчете среднего заработка для начисления очередного отпуска не исчисляются суммы районного коэффициента и северной надбавки? При исчислении среднего заработка во...
Посмотреть все результаты поиска похожих
Комментарии
Mokey
25.07.2012 09:53Комментарий: 2
Mokey
Код 1C v 8.х
 
СписокЗначений. ЗагрузитьЗначения(Результат.Выгрузить().ВыгрузитьКолонку("Ссылка"));
СписокЗначений. ЗаполнитьПометки(Истина);
Mokey
25.07.2012 09:52Комментарий: 1
Mokey
Что-то написано много лишнего. В запросе ставится условие на ПометкаУдаления = ИСТИНА, и потом ещё раз проверяется это условие уже в переборе результата. Надо стараться в одном месте делать проверку или выборку.
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.