helpf.pro
Регистрация
 0 
Распечатать

1С 8.x : Руководство компании, хочет получать оперативную сводку продаж по фирме

Руководство компании, хочет получать оперативную сводку продаж по фирме на свой почтовый ящик с обратной связью. То есть, посылая письмо на определенный ящик, программа составляет отчет о продажах на текущий день и отсылает на ящик отправителя.

Технический аспект реализации. на почтовом сервере компании заводим ящик autoreport.xxx.ru , в глобальный модуль в предопределенную процедуру ПриНачалеРаботыСистемы вставляем проверку строки запуска 1С для того, что бы определить момент старта проверки поступления новых писем в ящик.
Код 1C v 8.х
 
Процедура ПриНачалеРаботыСистемы()
Если Найти(ПараметрЗапуска,"changemail")>0 Тогда
Форма = Обработки.SaletoMail.ПолучитьФорму();
Форма.ОтсылкаПоЗаказу();
ЗавершитьРаботуСистемы(Ложь);
конецЕсли;
КонецПроцедуры


В планировщик задач вписываем запуск 1С Предприятия в “C:\Program Files\1cv8\bin\1cv8.exe” enterprise /DisableStartupMessages /smain\demo /cchangemail и ставим запуск каждые 5 минут. После запуска 1С проверяет переданный параметр если он подходит то происходит вызов внешней обработки в которой формируется отчет и происходит передача отчета обратно на ящик отправителя. Во внешнюю обработку писем процедуру ОтсылкаПоЗаказу() которая проверяет ящик на наличие писем, делает минимальную проверку , но то, что письмо пришло из нашего почтового сервера и отсылает продажи на адрес отправителя.

Код 1C v 8.х
 
Процедура ОтсылкаПоЗаказу()
Профиль = Новый ИнтернетПочтовыйПрофиль;
Профиль.АдресСервераSMTP = "mail.xxx.ru";
Профиль.АдресСервераPOP3 = "mail.xxx.ru";
Профиль.ПортSMTP = 25;
Профиль.ПортPOP3 = 110;
Профиль.Пользователь = "sale";
Профиль.Пароль = "Report";
Почта = Новый ИнтернетПочта;
Почта.Подключиться(Профиль);
Массив = Новый Массив; Сообщения = Почта.Выбрать(true ,Массив);
// true для того, что бы очистить обработанные сообщения
Для КолПисем= 1 По Сообщения.Количество() Цикл
ТекПисьмо = Сообщения.Получить(КолПисем-1);
Если (Найти(ТекПисьмо.Отправитель.Адрес,"xxx.ru")>0) and (НРег(ТекПисьмо.Тема)="magicsale") тогда Письмо = Новый ИнтернетПочтовоеСообщение; Письмо.ИмяОтправителя = "sale";
Сообщение = Новый ИнтернетПочтовоеСообщение;
Письмо.Тексты.Добавить("Продажи дня" + ТекущаяДата());
Письмо.Получатели.Добавить(""+Сообщения.Получить(КолПисем-1).Отправитель.Адрес);
// ….. Поскипано
// ….. Формируем отчет о продажах и сохраняем его во внешний файл , или текст.
// ….. вкладываем отчет как приатаченный файл или тело сообщения.
Почта.Послать(Письмо);
КонецЕсли;
КонецЦикла;
Почта.Отключиться();
КонецПроцедуры

Отправка отчетов из 1С по электронной почте (E-Mail)
Разместил:   Версии: | 8.x |  Дата:   Прочитано: 6421
 0 
Распечатать
Возможно, вас также заинтересует
SMTP greeting failure: 421 SMTP connection broken (reply) 2
Опи­са­ние ошиб­ки: С сен­тяб­ря 2014 Ян­декс.Почта, Mail.ru пе­ре­шли на про­то­кол SSL, что сде­ла­ло их еще более без­опас­ны­ми. Чтобы и даль­ше ра­бо­тать с пись­ма­ми через 1С, Вам нужно из­ме­нить их на­строй­ки и...
Как получить и отправить почту? (ИнтернетПочта, ИнтернетПочтовыйПрофиль, ИнтернетПочтовоеСообщение) 2
Отправка // отправка почтового сообщения... Профиль = новый ИнтернетПочтовыйПрофиль; Профиль.АдресСервераSMTP = " smtp.yandex.ru" ; Профиль.ПользовательSMTP = " 111" ; Профиль.ПарольSMTP = " 222222" ; // ПРофиль.АутентификацияSMTP =...
Механизм распределенных информационных баз 0
Механизм распределенных информационных баз предназначен для создания территориально распределенных систем на основе идентичных конфигураций 1С:Предприятия 8. Этот механизм позволяет переносить как данные 1С:...
Отправка sms из 1C через avisosms.ru. 0
Столкнулся с задачей отправки sms из 1С. Спасибо Якову за напутствие в решении данной задачи и указание сервиса avisosms.ru. На сайте сервиса предоставлена документация по работе с ним. В частности сервис предлагает...
Отправка отчетов из 1С по электронной почте (E-Mail) 0
Автоматическая генерация отчета " Анализ заказов поставщикам" Отчет анализ заказов является штатным отчетом конфигурации 1С Управление производственным предприятием. Обработка для генерации отчета,...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.