helpf.pro
Регистрация
 0 
Распечатать

Как получить и отправить почту? (ИнтернетПочта, ИнтернетПочтовыйПрофиль, ИнтернетПочтовоеСообщение)

Отправка
Код 1C v 8.2 УП
 // отправка почтового сообщения...
Профиль = новый ИнтернетПочтовыйПрофиль;
Профиль.АдресСервераSMTP = "smtp.yandex.ru";
Профиль.ПользовательSMTP = "111";
Профиль.ПарольSMTP = "222222"; //
ПРофиль.АутентификацияSMTP = СпособSMTPАутентификации.Login;

Сообщение = Новый ИнтернетПочтовоеСообщение;
Сообщение.Отправитель = "121@yandex.ru";
Сообщение.Тема = ""+ПрефиксФилиала;
Сообщение.Получатели.Добавить("12321@yandex.ru");
Сообщение.Тексты.Добавить(ТекстПисьма);
Сообщение.Вложения.Добавить(ИмяВременногоZiPфайла);

Почта = Новый ИнтернетПочта;
Попытка
Состояние("Отправка почтового сообщения...");
Почта.Подключиться(Профиль);
Почта.Послать(Сообщение);
Предупреждение("Сообщения успешно отправлены!");
Исключение
Сообщить("Ошибка соединения с сервером.",СтатусСообщения.ОченьВажное);
Сообщить(""+ОписаниеОшибки());
КонецПопытки;


Получение
Код 1C v 8.2 УП
 Профиль = новый ИнтернетПочтовыйПрофиль;
Профиль.АдресСервераPOP3 = "pop3.yandex.ru";
Профиль.Пользователь = "121";
Профиль.Пароль = "12321";
ПРофиль.АутентификацияPOP3 = СпособPOP3Аутентификации.Обычная;

Попытка
Предупреждение("Попытка подключения к серверу почты "+Профиль.АдресСервераPOP3);
Состояние("Подключение к серверу "+Профиль.АдресСервераPOP3);
Почта = Новый ИнтернетПочта;
Почта.Подключиться(Профиль);

МассивСообщений = Новый Массив;
Предупреждение("Чтение почтовых сообщений");
Состояние("Чтение почтовых сообщений...");
МассивСообщений = Почта.Выбрать(Ложь); // ЛОжь - письма с сервера не удаляются...
Исключение
Предупреждение("Ошибка подключения к серверу ","Остановить");
Предупреждение(""+ОписаниеОшибки(),"Остановить");
Сообщить("Ошибка подключения к серверу!");
Сообщить(""+ОписаниеОшибки());
Возврат;
КонецПопытки;

Если МассивСообщений.Количество() = 0 Тогда
Предупреждение("В почтовом ящике нет сообщений. Прерываем работу.");
Сообщить("Почтовый ящик пуст");
ПолученныеПисьма.Очистить();
Возврат;
КонецЕсли;
ОтобразитьПочтовыеПисьма();
КонецПроцедуры

Процедура ОтобразитьПочтовыеПисьма()
ПолученныеПисьма.Очистить();
Если МассивСообщений.Количество() = 0 Тогда
Возврат; // почтовых сообщений нету.
КонецЕсли;

Предупреждение("Начало отображения сообщений в обработке");
МассивСообщенийОбмена = новый Массив;

ИмяФайлаСообщения = "";
ПолученныеПисьма.Очистить();
Для Индекс = 0 По МассивСообщений.Количество() - 1 Цикл
стр = ПолученныеПисьма.Добавить();
стр.ДатаОтправления = МассивСообщений[Индекс].ДатаОтправления;
стр.ЗаголовокСообщения = МассивСообщений[Индекс].Заголовок;
стр.Индекс = Индекс;
стр.КоличествоВложений = МассивСообщений[Индекс].Вложения.Количество();
стр.КоличествоТекстов = МассивСообщений[Индекс].Тексты.Количество();
стр.Размер = МассивСообщений[Индекс].Размер;
стр.Тема = МассивСообщений[Индекс].Тема;
КонецЦикла;
Предупреждение("Сообщения отображены");
Разместил:   Версии: | 8.x | 8.2 УП |  Дата:   Прочитано: 15341
 0 
Распечатать
Возможно, вас также заинтересует
Как организовать работу с почтой без установленного почтового клиента на компьютере пользователя? 2
// Сформировать почтовый профиль. // При отправке нет необходимости указывать настройки, связанные с POP сервером. ИПП = Новый ИнтернетПочтовыйПрофиль; ИПП.АдресСервераSMTP = Константы.АдресСервераSMTP.Получить(); ...
Как организовать работу с электронной почтой через установленного почтового клиента? 0
// Отправка почты Почта = Новый Почта; Почта.Подключиться(" login" , " password" ); Сообщ = Новый ПочтовоеСообщение; Сообщ.Текст = " Вот файл!" ; Сообщ.Тема = " Срочно!!!" ; Данные = Новый ДвоичныеДанные(" c:file.txt" ); ...
Как организовать работу удаленных складов? 0
Процедура ПриОтправкеДанныхПодчиненному(ЭлементДанных, ОтправкаЭлемента) Если ТипЗнч(ЭлементДанных) = Тип(" ДокументОбъект.РеализацияТоваров" ) Тогда Если ЭлементДанных.Склад Склад Тогда ОтправкаЭлемента =...
Как с помощью интернет-почты создать письмо, содержащее HTML-текст с картинками? 0
Для этого нужно в текст письма добавить HTML-текст со ссылками на реальные картинки, находящиеся на диске. А после этого выполнить метод ОбработатьТексты(). Этот метод прочитает картинки с диска и поместит их в почтовое...
Конвертация данных 3.0. Настройка правил конвертации в формате Enterprise Data. Пример использования 18
Задача Передать информацию о контрагентах из УП в БП . Данные передаются в одностороннем порядке, идентификация производится по уникальному идентификатору.Настройка правил конвертации выполняется с помощью...
Посмотреть все результаты поиска похожих
Комментарии
gamograff
27.07.2015 12:47Комментарий: 1
gamograff

Добрый день. Делаю отправку почты аналогично, использую Яндекс. При отладке вылетает ошибка: "Ошибка времени выполнения: Ошибка при вызове метода контекста (Послать)". С чем это может быть связано? Настройки почтового профиля верны, в ящике работа с почтовыми программами настроена.

Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.