helpf.pro
Регистрация
 0 
Распечатать

1С 8.x : Функция выборки данных из SQL сервера и передача во временную таблицу 1С

Код 1C v 8.х
 Функция ЗапросSQL (SQLServer,Login,Password,ЗапросSQL)

СтрокаСоединения = ("Driver={SQL Server}; Deleted=No; Data Source = ") + SQLServer +
(";UID=") + Login + ("; PWD=") + Password + (";");

СоединениеSQL = Новый ComObject("ADODB.Connection");
СоединениеSQL.ConnectionString=СтрокаСоединения;
Попытка
СоединениеSQL.Open();
Состояние ("Подключение к серверу SQL...");
Исключение
Сообщить(ОписаниеОшибки());
Возврат Ложь;
КонецПопытки;

Состояние ("Выполнение запроса SQL...");
ЗаписиSQL = Новый ComObject("ADODB.RecordSet");
ЗаписиSQL.ActiveConnection = СоединениеSQL;
ЗаписиSQL = СоединениеSQL.Execute (ЗапросSQL);

Таблица = Новый ТаблицаЗначений;
Состояние ("Заполнение временной таблицы...");
Для НомерСтолбца = 0 По ЗаписиSQL.Fields.Count-1 Цикл //Создание и добавление колонок во временную таблицу
ИмяСтолбца =ЗаписиSQL.Fields.Item(НомерСтолбца).Name;
Таблица.Колонки.Добавить(ИмяСтолбца);
//Сообщить(ИмяСтолбца);
КонецЦикла;

Пока ЗаписиSQL.EOF=0 Цикл // Заполнение созданной таблицы

НоваяСтрока = Таблица.Добавить();
Для НомерСтолбца = 0 По ЗаписиSQL.Fields.Count-1 Цикл
НоваяСтрока.Установить(НомерСтолбца,ЗаписиSQL.Fields(НомерСтолбца).Value);
//Сообщить ("Test " + ЗаписиSQL.Fields(ИмяСтолбца).Value + ИмяСтолбца);
КонецЦикла;

ЗаписиSQL.MoveNext();

КонецЦикла;

Состояние ("Закрываем соединение с SQL...");
ЗаписиSQL.Close();
СоединениеSQL.Close();

Возврат Таблица; // Возврат таблицы значений запроса SQL

КонецФункции
Разместил:   Версии: | 8.x |  Дата:   Прочитано: 8596
 0 
Распечатать
Возможно, вас также заинтересует
Временные таблицы 0
Не помню уже с какого релиза в запросах стало можно использовать временные таблицы. Для этого используется объект «Менеджер временных таблиц». Фактически менеджер временных таблиц описывает пространство имен...
Временные таблицы, как удалить? 0
// Как удалить Временную Таблицу Запрос = Новый Запрос; Запрос.МенеджерВременныхТаблиц = МенеджерВТ; // (Менеджер ВТ создан, в нем уже есть временная таблица ИмяВременнойТаблицы) ТекстЗапpoca = " | УНИЧТОЖИТЬ...
Временные таблицы, что из себя представляют и как с ними работать? 5
Временные таблицы - хранятся на сервере и позволяют писать более простые запросы. Временные таблицы хранятся в объекте типа МенеджерВременныхТаблиц . Когда этот объект уничтожается, уничтожаются и временные...
Загрузить данные в 1с из текстового файла с разделителями 1
В этой статье я расскажу, как загружать данные в 1с 8 из простейших текстовых файлов с разделителями. Обычно они имеют расширение csv (Comma-Separated Values). Т. е. название подразумевает, что в каждой строке такого текстового файла...
Заполнение табличного поля данными таблицы значений, полученной из SQL - Запроса 0
Процедура ЗаполнитьНажатие(Элемент) запрос = СоставитьЗапрос(); //Функция СоставитьЗапрос() возвращает строку запроса ТаблицаВывода = Новый ТаблицаЗначений; ТаблицаВывода.Очистить(); ТаблицаВывода =...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.