helpf.pro
Регистрация
 0 
Распечатать

1С 8.x : Реквизит ~ Функция проверяет, все ли реквизиты элемента заполнены(Краткий вариант проверки)?

Код 1C v 8.х
 // Возвращаемое значение:
// Ложь ,если не все реквизиты заполнены
// Истина, если все отмеченные реквизиты заполнены

Функция ПроверитьНезаполненныеРеквизиты(Элементы) Экспорт
Для каждого стр Из Элементы Цикл
Если ТипЗнч(стр)=Тип("ПолеВвода") И стр.АвтоОтметкаНезаполненного И
НЕ ЗначениеЗаполнено(стр.Значение) Тогда
Если стр.Имя=стр.Подсказка Тогда
стрПодсказка="";
Иначе
стрПодсказка=" : "+стр.Подсказка;
КонецЕсли;
Возврат "Не заполнено поле "+стр.Имя+стрПодсказка;
КонецЕсли;
КонецЦикла;
Возврат "";
КонецФункции
Разместил:   Версии: | 8.x | 8.2 УП |  Дата:   Прочитано: 13485
 0 
Распечатать
Возможно, вас также заинтересует
В отчет не попадают данные за последний день… Как исправить? 0
Пользователь выбрал период формирования отчета с 1июля по 31. Почему при формировании отчета в него не попадают данные за 31 число? На самом деле, это одна из самых распространенных ошибок при разработке отчетов. В 1С 8.х дата содержит время с точно
Ввод документа на основании - Программно 11
НовДок = Документы.ПеречислениеНДФЛвБюджет.СоздатьДокумент(); //Заполнить - вызывает ОбработкаЗаполнения(Основание) в документе ПеречислениеНДФЛвБюджет НовДок.Заполнить(ЭлементыФормы.ДокументСписок.ТекущаяСтрока); НовДок.ПолучитьФорму().Открыть()
где в УТ 2.1 заполнить счета учета расчетов с контрагентами? 0
1с Предприятие Управление торговлей 2.1 Не проводится документ Поступление товаров и услуг. Ошибка - не заполнены оба счета. Не могу найти, где заполнить счета учета расчетов с контрагентами
Заполним "ТЗПолучатель" данными таблицы значений "ТЗИсходная" Краткий вариант 0
ТЗПолучатель = ТЗИсходная.Скопировать(); // или так Для Каждого СтрокаИсходнойТаблицы Из ИсходнаяТаблица Цикл НоваяСтрока = ТЗПолучатель.Добавить(); ЗаполнитьЗначенияСвойств(НоваяСтрока, СтрокаИсходнойТаблицы); КонецЦикла;
Как в периодическом независимом регистре сведений удалить все записи по валютам с наименованиями? 0
Как в периодическом независимом регистре сведений «КурсыВалют» удалить все записи по валютам с наименованиями «EUR» и «USD», период которых меньше 01 января 2005 года? Сначала получим таблицу записей, которые необходимо оставить. Поскольку условий
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.