helpf.pro
Регистрация
 +2 
Распечатать

1С 8.x : Перебор дат, заполнение списка, массива дат по порядку

Код 1C v 8.х
  // Укажем период	
ДатаН = Дата(2008,1,1);
ДатаК = Дата(2009,12,31);



// В Список значений поместим перебором каждую дату за период
СписокДат = Новый СписокЗначений;
ТекДата = ДатаН;
Пока ТекДата < ДатаК Цикл
СписокДат.Добавить(ТекДата);
// Увеличение ровно на одни сутки
ТекДата = ТекДата + 60 * 60 * 24;
КонецЦикла;
СписокДат.Добавить(ТекДата);



//В Массив добавим каждый первый день месяца за период
МассивДат = Новый Массив;
ТекДата = ДатаН;
Пока ТекДата < ДатаК Цикл
МассивДат.Добавить(ТекДата);
// Для получения даты следющего месяца на Конец Дня,
// получаем дату конца месяца текущей даты и плюс одни сутки
//ТекДата = КонецМесяца(ТекДата) + 60 * 60 * 24;
// Для получения даты следющего месяца на Начало Дня,
// получаем дату конца месяца текущей даты и плюс один
ТекДата = КонецМесяца(ТекДата) + 1;
КонецЦикла;
Разместил:   Версии: | 8.x |  Дата:   Прочитано: 11060
 +2 
Распечатать
Возможно, вас также заинтересует
1С Предприятие что это? 6
Что такое 1С? 1С — это фирма , у которой одно из направлений деятельности — разработка программного обеспечения для автоматизации бизнес-процессов предприятий. « 1С:Предприятие » - конкретный продукт, который...
COM-подключение к базе 7.7 из 8.2 1С 4
Если код выполняется на стороне клиента, то необходимо наличие базы 7.7 на локальной машине. Пример (На форме объекта присутствует реквизит Таблица(ТаблицаЗначений)): НаКлиенте Процедура Загрузки() ПутьКБазе="...
Cклонения по падежам 4
НаКлиенте Процедура Команда1(Команда) ФИО = " Иванов Иван Иванович" ; Падеж = 2; Пол = 1; Результат = СклонениеФИО(ФИО, Падеж, пол); Сообщить(Результат); КонецПроцедуры НаСервере Функция СклонениеФИО(ФИО, Падеж, пол) ...
Cообщение: "Не удалось удалить чеки ККМ!" 2
Пользователь с правами Администратор ККМ проводит Закрытие кассовой смены (Z). Выходит сообщение: " Не удалось удалить чеки ККМ!" ФР печатает Z -отчет, но Отчет о рознчничных продажах не формируется. Необходимо дать...
Excel файл как Внешний источник данных 4
Подключимся и загрузим из файла Excel данные в таблицу значений 1С. Сделать теперь это очень просто. 1. В конфигурации добавляет новый объект метаданных типа " Внешние источники данных" и назовем его просто " Excel" . ...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.