helpf.pro
Регистрация
 +3 
Распечатать

1С 8.x : Как программно открыть и выбрать элемент справочника, выбор элемента справочника?

Просто открыть:
Код 1C v 8.х
  // Получить форму выбора справочника как подчиненную форме документа 
ФормаСписка = Справочники.Номенклатура.ПолучитьФормуСписка( , ЭтаФорма);
// Открыть полученную форму
ФормаСписка.Открыть();



Открыть для выбора элемента:
Код 1C v 8.х
  ФормаВыбора = Справочники.Номенклатура.ПолучитьФормуВыбора( , ЭтаФорма); 
ФормаВыбора.Заголовок = "Выберите товар!";
Выбрано = ФормаВыбора.ОткрытьМодально();


Открыть справочник для выбора элемента и установить отбор:
Код 1C v 8.х
  // Если Отобрать = Истина, то откроется выборка справочника без элементов у которых ГруппыПользователей.ВсеПользователи
Если Отобрать Тогда
ФормаВыбора = Справочники.ГруппыПользователей.ПолучитьФормуВыбора();
ФормаВыбора.Отбор.Ссылка.Установить(Справочники.ГруппыПользователей.ВсеПользователи);
ФормаВыбора.Отбор.Ссылка.ВидСравнения = ВидСравнения.НеРавно;
Иначе
ФормаВыбора = Справочники.Пользователи.ПолучитьФормуВыбора();
КонецЕсли;
// укажем что выбирать только элементы
ФормаВыбора.ПараметрВыборГруппИЭлементов = ИспользованиеГруппИЭлементов.Элементы;
ВыбранноеЗначение = ФормаВыбора.ОткрытьМодально();



Примеры использования событий(Вывели на форму поле елемента справочника, в его свойствах есть события)
Код 1C v 8.х
  Процедура ПолеВводаНачалоВыбора(Элемент, СтандартнаяОбработка) 

// Запретить стандартную обработку.
СтандартнаяОбработка = Ложь;

// Получить форму выбора справочника как подчиненную полю ввода.
ФормаВыбора = Справочники.Номенклатура.ПолучитьФормуВыбора( , Элемент);

// Открыть полученную форму
ФормаВыбора.Открыть();

КонецПроцедуры

Процедура ПолеВводаОбработкаВыбора(Элемент, ВыбранноеЗначение, СтандартнаяОбработка)
// Отключить стандартную обработку (при необходимости).
СтандартнаяОбработка = Ложь;

ПолученноеЗначение = ВыбранноеЗначение;
// Дальнейшая обработка значения.
КонецПроцедуры
Разместил:   Версии: | 8.x |  Дата:   Прочитано: 36143
 +3 
Распечатать
Возможно, вас также заинтересует
COM-соединение не обнаружило свободной лицензии / ключ защиты 0
Иногда при подключении к 1С возникает ошибка: COM-соединение не обнаружило свободной лицензии! COM-соединение не обнаружило ключ защиты программы! https://helpf.pro/uploads/img/_1-UsuyAg6E2P.jpg В таких случаях, иногда, может помочь...
ZIP-архив Создание 0
Для того чтобы записать файлы в ZIP-архив необходимо выполнить несколько простых действий: * Создать архив с необходимыми параметрами, в который будут помещаться файлы. * Поместить в архив необходимые файлы. * Записать...
ZIP-архив Чтение 0
Для того чтобы прочитать файлы из ZIP-архива необходимо выполнить несколько простых действий: - Открыть необходимый архив - Распаковать файлы Создание объекта ЧтениеZIPФайла можно осуществить двумя путями - создать...
Активация открытой книги Excel для корректировки 0
Нужно было получить для изменения уже открытую книгу Excel, а если она закрыта, то открыть и изменять. Ниже код, который данную задачу решает. Попытка Эксель = Неопределено; Книга = Неопределено; Лист = Неопределено; ...
Битая ссылка, <Объект не найден>, Уникальный Идентификатор, GUID 21
Когда кто-то удаляет данные из базы без проверки ссылок на эти объекты, то везде где этот объект использовался появляется сообщение вида: Объект не найден (84:bf5600145e3710ab11dda4c605dbe824) . https://helpf.pro/uploads/img/_1-46z7I4U7Ww.png В
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.