helpf.pro
Регистрация
 0 
Распечатать

1С 8.x : Функция выделяет из имени файла его расширение

Код 1C v 8.х
 
// Функция выделяет из имени файла его расширение
//
// Параметры
// ИмяФайла – Строка, содержащая имя файла, неважно с именем каталога или без.
//
// Возвращаемое значение:
// Строка – расширение файла.
//
Функция ПолучитьРасширениеФайла(ИмяФайла) Экспорт

ПозицияПоследнейТочки = 0;
РасширениеФайла = ИмяФайла;

Пока 1 = 1 Цикл

ПозицияПоследнейТочки = Найти(РасширениеФайла, ".");

Если ПозицияПоследнейТочки = 0 Тогда

Прервать;

Иначе

РасширениеФайла = Сред(РасширениеФайла, ПозицияПоследнейТочки + 1)

КонецЕсли;

КонецЦикла;

Возврат ?(РасширениеФайла = ИмяФайла, "", РасширениеФайла);

КонецФункции
Разместил:   Версии: | 8.x |  Дата:   Прочитано: 8202
 0 
Распечатать
Возможно, вас также заинтересует
1C и Google Maps 12
была поставлена задача отображения на географической карте медицинских учреждений. После обзора предлагаемых решений был выбран сервис google. Но так же подобного рода подход будет работать и с картами сервиса yandex. Во...
1Cv8.1CD - Файл данных достиг максимального размера! 3
1С выдает предупреждение " Файл данных достиг максимального размера" . Подскажите из - за чего это и как можно решить ? Превышен размер файла, обычно это сообщение возникает, когда размер файла 1Cv8.1CD приближается к 10...
Excel файл как Внешний источник данных 4
Подключимся и загрузим из файла Excel данные в таблицу значений 1С. Сделать теперь это очень просто. 1. В конфигурации добавляет новый объект метаданных типа " Внешние источники данных" и назовем его просто " Excel" . ...
QR код в 1С 10
Столкнулся с интересной задачей реализации генерации QR-кода в 1С 8.2 ( QR-код — матричный код (двухмерный штрихкод) ) Для генерации было использовано api от google (http://chart.apis.google.com/chart). Вот сайт , который работает с ним. После...
ZIP-архив Разделить и Объединить Файл 0
При работе с большими объемами данных могут возникнуть проблемы при пересылке архивных файлов. Типичной такой ситуацией является ограничение некоторых почтовых серверов на размер сообщения - если письмо превышает...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.